aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Wickman <wick...@apache.org>
Subject Re: Problems building Thermos
Date Fri, 05 Sep 2014 15:40:25 GMT
Not a silly question at all.  The error messages could definitely be more
helpful.

Out of curiosity, do you have the python-dev package and compiler toolchain
installed into this image?  psutil has C extensions and it's possible that
pants simply can't get python to build them.

For mesos, one possibility of why it reports inability to resolve the
dependency could be pants itself attempting to build a python 2.6 executor,
so the 2.7 egg wouldn't be useful.  You could try ./pants build -i
'CPython>=2.7,<3'  src/main/python/apache/aurora/executor/bin:thermos_executor
to force pants to use python 2.7.  See if that affects whether or not it
can find a valid mesos egg.

Hope that helps!
~brian


On Fri, Sep 5, 2014 at 8:32 AM, Jeffrey Davis <jeffrey.n.davis@gmail.com>
wrote:

> Hi all -
>
> I'm in the process of setting up a ~small aurora cluster, but appear to
> have hit a wall w/ building Thermos.  I tried breaking out portions of
> aurorabuild.sh, but I think there's an environmental issue that's been
> preset on the vagrant image.
>
> For both:
>      ./pants src/main/python/apache/aurora/executor/bin:gc_executor
>      ./pants src/main/python/apache/aurora/executor/bin:thermos_executor
> I get an error for an unmet dependency for mesos-0.19.1.  From KTS in the
> IRC room, I tried creating a third_party directory at the base of the
> project and dropping the file mesos-0.19.1-py2.7-linux-x86_64.egg there,
> but to no avail.  I tried various naming combinations, and also tried
> dropping it in /3rdparty/python ( from the project base ).
>
> Finally, for
>    ./pants src/main/python/apache/aurora/executor/bin:thermos_runner
> I get:
>      Untranslateable: Package SourcePackage(u'
>
> https://pypi.python.org/packages/source/p/psutil/psutil-1.1.2.tar.gz#md5=fe9c9a3ed95fe6564acf8b4500c7b5da
> ')
>
> My apologies if this is a vacuous question - my python skill set is not
> that great, so trying to understand how pants puts things together has been
> challenging.
>
> For our current system, uname -a gives: Linux vagrant-debian-wheezy
> 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux
>
> Thanks!
>
> Jeff Davis
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message