aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renan DelValle <rdelv...@binghamton.edu>
Subject Gradle 2.3.3
Date Tue, 05 Aug 2014 02:33:22 GMT
Hi,

I'm trying to build Aurora as the instructions indicate but it runs into an
error.

I'm running the latest Gradle available from their website (2.0) which
includes Groovy 2.3.3 which seems to be the source of the issue. I'm trying
to compile version 0.5.0-RC2.

Here's the error:

* What went wrong:

Could not compile build file
'/home/test/apache-aurora-0.5.0-rc2-incubating/build.gradle'.

> startup failed:

  Could not instantiate global transform class
org.spockframework.compiler.SpockTransform specified at
jar:file:/home/test/.gradle/caches/modules-2/files-2.1/org.spockframework/spock-core/0.7-groovy-1.8/3a677d19e8d3acf3bd296c4023356256d55da5a3/spock-core-0.7-groovy-1.8.jar!/META-INF/services/org.codehaus.groovy.transform.ASTTransformation
because of exception
org.spockframework.util.IncompatibleGroovyVersionException: The Spock
compiler plugin cannot execute because Spock 0.7.0-groovy-1.8 is not
compatible with Groovy 2.3.3. For more information, see
http://versioninfo.spockframework.org

  Spock location:
file:/home/test/.gradle/caches/modules-2/files-2.1/org.spockframework/spock-core/0.7-groovy-1.8/3a677d19e8d3acf3bd296c4023356256d55da5a3/spock-core-0.7-groovy-1.8.jar

  Groovy location: file:/home/test/gradle-2.0/lib/groovy-all-2.3.3.jar


Any help is greatly appreciated.


-Renan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message