aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Burg <kb...@foursquare.com>
Subject Task Constraints
Date Sat, 12 Jul 2014 00:24:20 GMT
Hi,

I'm having trouble getting the task constraint resolver worker with
attributes other than 'host' and 'rack.' Are arbitrary attribute keys in
the mesos slaves supported currently?

Here is the setup.

The slaves are configured to run with
`--attributes=host:<host>;rack:<rack>;staging:true`

(I've also tried this with staging:1, and staging:foo)

The constraint generated from the .aurora config looks like the following
Constraint(name:staging, constraint:<TaskConstraint
value:ValueConstraint(negated:false, values:[true])>)

The schedule request then gets vetoed with the following veto object:
Veto{reason=Constraint not satisfied: staging, score=1000,
valueMismatch=true}]

The constraints generated for 'host' and 'rack' look identical except for
the different name of course. I've even tried bouncing every mesos and
aurora process on the machine to see if maybe stale attributes were being
assigned to the slaves. All the offers being made to the master look
correct though, which leads me to believe that the constraint solver just
doesn't work for arbitrary attributes.

We would appreciate any help you can offer.

Thanks,
Kevin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message