aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AURORA-42) Modify client side code to distinguish between api objects
Date Fri, 17 Jan 2014 20:31:20 GMT

    [ https://issues.apache.org/jira/browse/AURORA-42?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13875235#comment-13875235
] 

Hudson commented on AURORA-42:
------------------------------

SUCCESS: Integrated in Aurora #55 (See [https://builds.apache.org/job/Aurora/55/])
Revert "Get rid of ambiguities about exactly what object is being used to send calls to the
scheduler. (See AURORA-42)." (mchucarroll: rev 813bfc2bfb54a56c5e9a03dcfefb3271ecce1790)
* src/test/python/apache/aurora/client/api/test_job_monitor.py
* src/test/python/apache/aurora/client/commands/test_status.py
* src/test/python/apache/aurora/client/commands/test_cancel_update.py
* src/test/python/apache/aurora/client/commands/test_restart.py
* src/main/python/apache/aurora/client/api/job_monitor.py
* src/test/python/apache/aurora/client/cli/test_create.py
* src/test/python/apache/aurora/client/cli/util.py
* src/test/python/apache/aurora/client/cli/test_kill.py
* src/main/python/apache/aurora/client/api/__init__.py
* src/main/python/apache/aurora/client/api/scheduler_client.py
* src/test/python/apache/aurora/client/commands/test_create.py
* src/test/python/apache/aurora/client/commands/test_ssh.py
* src/test/python/apache/aurora/client/cli/test_diff.py
* src/test/python/apache/aurora/client/cli/test_status.py
* src/test/python/apache/aurora/client/commands/test_listjobs.py
* src/test/python/apache/aurora/client/commands/test_diff.py
* src/test/python/apache/aurora/client/commands/test_kill.py
* src/test/python/apache/aurora/client/commands/test_run.py
* src/test/python/apache/aurora/client/commands/util.py
* src/test/python/apache/aurora/client/commands/test_update.py
* src/main/python/apache/aurora/client/commands/core.py


> Modify client side code to distinguish between api objects
> ----------------------------------------------------------
>
>                 Key: AURORA-42
>                 URL: https://issues.apache.org/jira/browse/AURORA-42
>             Project: Aurora
>          Issue Type: Task
>          Components: Client
>            Reporter: Mark Chu-Carroll
>            Assignee: Mark Chu-Carroll
>
> In client work, especially writing tests, the term "scheduler" is overloaded in the code,
and this makes diagnosing and debugging failures difficult.
> An aurora API object contains a property named "scheduler", which is a reference to a
SchedulerProxy. A SchedulerProxy, in turn, contains a property named "scheduler", which is
actually a reference to a SchedulerClient.
> As a result, code frequently reads "foo. scheduler.scheduler.something"; in tests, when
you see a "scheduler" parameter, it's either a SchedulerProxy or a SchedulerClient, with no
good way to distinguish. This is especially problematic when you see a test failure: foo.
scheduler didn't get an expected call; what is foo.scheduler?
> To clear this mess up, we should get rid of the "scheduler" fields, and rename them to
make clear what they are: api contains a field "scheduler_proxy"; SchedulerProxy contains
a field "scheduler_client".



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message