aurora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Chu-Carroll (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AURORA-42) Modify client side code to distinguish between api objects
Date Thu, 16 Jan 2014 16:32:19 GMT
Mark Chu-Carroll created AURORA-42:
--------------------------------------

             Summary: Modify client side code to distinguish between api objects
                 Key: AURORA-42
                 URL: https://issues.apache.org/jira/browse/AURORA-42
             Project: Aurora
          Issue Type: Task
          Components: Client
            Reporter: Mark Chu-Carroll
            Assignee: Mark Chu-Carroll


In client work, especially writing tests, the term "scheduler" is overloaded in the code,
and this makes diagnosing and debugging failures difficult.

An aurora API object contains a property named "scheduler", which is a reference to a SchedulerProxy.
A SchedulerProxy, in turn, contains a property named "scheduler", which is actually a reference
to a SchedulerClient.

As a result, code frequently reads "foo. scheduler.scheduler.something"; in tests, when you
see a "scheduler" parameter, it's either a SchedulerProxy or a SchedulerClient, with no good
way to distinguish. This is especially problematic when you see a test failure: foo. scheduler
didn't get an expected call; what is foo.scheduler?

To clear this mess up, we should get rid of the "scheduler" fields, and rename them to make
clear what they are: api contains a field "scheduler_proxy"; SchedulerProxy contains a field
"scheduler_client".




--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message