aurora-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wick...@apache.org
Subject git commit: Pull cherrypy from remote repository.
Date Wed, 30 Apr 2014 22:41:08 GMT
Repository: incubator-aurora
Updated Branches:
  refs/heads/master d8301a6de -> 639c4634f


Pull cherrypy from remote repository.

Testing Done:
mba=aurora=; PANTS_VERBOSE=1 PYTHON_VERBOSE=1 ./pants src/main/python/apache/thermos/observer/bin:thermos_observer

before:
Unsatisfiable: Cannot satisfy requirements: [PythonRequirement(cherrypy==3.2.2)]

after:
Wrote /Users/wickman/clients/aurora/dist/thermos_observer.pex

Bugs closed: AURORA-368

Reviewed at https://reviews.apache.org/r/20917/


Project: http://git-wip-us.apache.org/repos/asf/incubator-aurora/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-aurora/commit/639c4634
Tree: http://git-wip-us.apache.org/repos/asf/incubator-aurora/tree/639c4634
Diff: http://git-wip-us.apache.org/repos/asf/incubator-aurora/diff/639c4634

Branch: refs/heads/master
Commit: 639c4634f88e1b9f7c36ee5451070bdf5d811a61
Parents: d8301a6
Author: Brian Wickman <wickman@apache.org>
Authored: Wed Apr 30 15:41:02 2014 -0700
Committer: Brian Wickman <wickman@apache.org>
Committed: Wed Apr 30 15:41:02 2014 -0700

----------------------------------------------------------------------
 3rdparty/python/BUILD | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-aurora/blob/639c4634/3rdparty/python/BUILD
----------------------------------------------------------------------
diff --git a/3rdparty/python/BUILD b/3rdparty/python/BUILD
index cf0d29e..122f71d 100644
--- a/3rdparty/python/BUILD
+++ b/3rdparty/python/BUILD
@@ -18,7 +18,13 @@ COMMONS_VERSION = '0.3.0'
 
 python_requirement('argparse==1.2.1')
 python_requirement('bottle==0.11.6')
-python_requirement('cherrypy==3.2.2')
+# As of twitter.pants==0.0.23, we no longer pull in dependencies transitively from
+# pypi (the equivalent of --allow-external in pip.)  We must specify explicitly
+# the repository link for anything whose distribution is not available directly from
+# repos specified in pants.ini.
+python_requirement(
+    'cherrypy==3.2.2',
+    repository='http://download.cherrypy.org/cherrypy/3.2.2/')
 python_requirement('Flask==0.9')
 python_requirement('mako==0.4.0')
 python_requirement('mesos==0.18.0')


Mime
View raw message