attic-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <bay...@apache.org>
Subject Re: A helping hand with ant please.
Date Tue, 04 Apr 2017 02:56:04 GMT
Run 'ant' in the attic/site directory (i.e. the parent to xdocs, not in
xdocs itself).

Happy to offer more info, but I suspect that's what was going wrong for
you. I've updated the process.xml page to try to be clearer about that.

On why xdocs/Anakia: It's basically used to stop repeating html on every
page. Header, navbar, resource-table macro.

Hen


On Mon, Apr 3, 2017 at 8:57 AM, jan iversen <jancasacondor@gmail.com> wrote:

> Hi
>
> I have been fighting to get ant into my mac environment without destroying
> my other setups, that seems to work.
>
> However if I stand in xdocs and do "ant" it tells me it missed build.xml
>
> if I do "ant -f process.xml" it tells me:
>
> jan:xdocs jani$ ant -f process.xml
>
> Buildfile: /Volumes/LIBREOFFICE/apache/attic/site/xdocs/process.xml
>
>
> BUILD FAILED
>
> /Volumes/LIBREOFFICE/apache/attic/site/xdocs/process.xml:20: Unexpected
> element "{}document" {antlib:org.apache.tools.ant}document
>
>
> Total time: 0 seconds
>
> Please give me a hand.
>
> A short question, why use xdocs at all, all our pages are static, and we do
> not retire that many projects, so it would be just as easy to use html
> editor to update the html directly ?
>
> rgds
> jan I.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message