atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Johannes Mayer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-2249) Upgrade Atlas Client to use Jersey 2
Date Tue, 09 Oct 2018 13:59:00 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-2249?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16643473#comment-16643473
] 

Johannes Mayer commented on ATLAS-2249:
---------------------------------------

[~ppadovani] could you explain to me how i can apply this patch and and build myself? This
is the first time for me

which version / release do i need to check out? 1.0.0?

when i run git apply --check <path_to_patch> i get error: patch does not apply

> Upgrade Atlas Client to use Jersey 2
> ------------------------------------
>
>                 Key: ATLAS-2249
>                 URL: https://issues.apache.org/jira/browse/ATLAS-2249
>             Project: Atlas
>          Issue Type: Improvement
>          Components: atlas-intg
>    Affects Versions: 1.0.0
>            Reporter: Pierre Padovani
>            Priority: Major
>              Labels: patch-available
>         Attachments: client-jersey2-V2.patch, client-jersey2-V3.patch, client-jersey2-V4.patch,
client-jersey2.patch
>
>
> Using the existing Atlas client within a Jersey 2 service causes conflicts. I recommend
upgrading just the client code to Jersey 2. The enclosed patch fully upgrades the V1 and V2
client to Jersey 2, and we have tested this against our own installation of 1.0.0-SNAPSHOT.
> NOTE: We have not tested SSL/Kerberos authentication/security



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message