atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shankesi Mahender <shank...@gmail.com>
Subject Re: Need Help!!! Atlas Installation Error
Date Thu, 11 Oct 2018 20:09:49 GMT
Please find attached the application log. Did some more debugging and found
out that starting cassandra is an issue.

Any help would be greatly appreciated.

I  got at one situation where I can't proceed further.

Regards,
Mahender

On Thu, Oct 11, 2018 at 12:56 PM Shankesi Mahender <shankesi@gmail.com>
wrote:

> Madhan/Dev team,
>
> I'm able to install by changing the command  mvn clean -DskipTests package
> -Pdist,embedded-cassandra-solr
>
> I faced the same issue with executing the curl command again..
>
> $
> <idtooleval@data-management-tools-eval:~/mahen/apache-atlas-sources-1.1.0/distro/target/apache-atlas-1.1.0/bin$>
> curl -u admin:admin http://myip:21000/api/atlas/admin/version
> <http://10.41.64.19:21000/api/atlas/admin/version>
>
> curl: (7) Failed to connect to myip port 21000: Connection refused
>
> $
> <idtooleval@data-management-tools-eval:~/mahen/apache-atlas-sources-1.1.0/distro/target/apache-atlas-1.1.0/bin$>
> curl -u admin:admin https://myip/api/atlas/admin/version
> <https://10.41.64.19:21443/api/atlas/admin/version>
>
> curl: (7) Failed to connect to myip port 21443: Connection refused
>
>
> I went to atlas_config.py and change the DEFAULT_ATLAS_SERVER_HOST to my
> ip. None of them seems to be working.
>
>
>
> $ netstat -a | grep 21000
>
> netstat -a | grep 21443
>
>
> Didn't return anything.
>
> Do I need to do anything extra which is not documented in the instructions?
>
> Thanks for your help.
>
> Mahender
>
> On Wed, Oct 10, 2018 at 11:54 PM Shankesi Mahender <shankesi@gmail.com>
> wrote:
>
>> Dev team,
>>
>> I'm able to install when I changed the command like below.
>>
>> mvn clean -DskipTests package -Pdist,embedded-cassandra-solr.
>>
>> After that when I started apache server I'm getting the below error.
>>
>>  File "atlas_start.py", line 107
>>     print "Cannot run setup when server is running."
>>                                                    ^
>> SyntaxError: Missing parentheses in call to 'print'
>>
>> I tried to stop the server if it is already started but I got the same
>> kind of error.
>>
>> File "atlas_stop.py", line 63
>>     print "Apache Atlas Server stopped!!!\n"
>>                                            ^
>> SyntaxError: Missing parentheses in call to 'print'
>>
>> Can  anyone help me on this?
>>
>> Thanks,
>> Mahender
>>
>>
>>
>> On Wed, Oct 10, 2018 at 4:23 PM Mahender Shankesi <shankesi@gmail.com>
>> wrote:
>>
>>> I changed it but still not working.
>>>
>>> Mahender
>>>
>>> Sent from my iPhone
>>>
>>> On Oct 10, 2018, at 4:03 PM, Madhan Neethiraj <madhan@apache.org> wrote:
>>>
>>> (copying dev list)
>>>
>>>
>>>
>>> Mahender – the port # to use is “21000”; the curl commands you listed
>>> show “2100”. Please try after correcting this.
>>>
>>>
>>>
>>> @Pierre – perhaps you can help with the question on Cassandra?
>>>
>>>
>>>
>>> Madhan
>>>
>>>
>>>
>>>
>>>
>>> *From: *Shankesi Mahender <shankesi@gmail.com>
>>> *Date: *Wednesday, October 10, 2018 at 12:37 PM
>>> *To: *"madhan@apache.org" <madhan@apache.org>
>>> *Subject: *Re: Need Help!!! Atlas Installation Error
>>>
>>>
>>>
>>> Madhan,
>>>
>>>
>>>
>>> I followed the instructions in the below site..
>>>
>>>
>>>
>>> https://atlas.apache.org/InstallationSteps.html
>>>
>>>
>>>
>>> I did it in two machines one Azure VM and one Azure Hdinisights.
>>>
>>>
>>>
>>> Hdinsights I'm able to install all steps correctly and run apache_start
>>> properly. However I'm not able to run the curl command..
>>>
>>>
>>>
>>> sshuser@XXX:~/xyz/apache-atlas-sources-1.1.0/distro/target/apache-atlas-1.1.0/bin$
>>> curl -u admin:admin
>>> https://xxx.azurehdinsight.net:2100/api/atlas/admin/version
>>>
>>> ^C
>>>
>>> sshuser@xxx:~/xxx/apache-atlas-sources-1.1.0/distro/target/apache-atlas-1.1.0/bin$
>>> curl -u admin:admin https://localhost:2100/api/atlas/admin/version
>>>
>>> curl: (7) Failed to connect to localhost port 2100: Connection refused
>>>
>>>
>>>
>>>
>>>
>>> However I'm facing challenges in install the steps in VM..
>>>
>>>
>>>
>>> mvn clean package -Pdist,embedded-cassandra-solr
>>>
>>>
>>>
>>> I'm getting the below error and it is hanging there..
>>>
>>>
>>>
>>>
>>> pache.atlas.repository.graphdb.janus.AtlasJanusGraphDatabase.getGraphInstance(AtlasJanusGraphDatabase.java:117)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraph.<init>(AtlasJanusGraph.java:93)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraphDatabase.getGraphInstance(AtlasJanusGraphDatabase.java:117)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraph.<init>(AtlasJanusGraph.java:93)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraphDatabase.getGraphInstance(AtlasJanusGraphDatabase.java:117)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraph.<init>(AtlasJanusGraph.java:93)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraphDatabase.getGraphInstance(AtlasJanusGraphDatabase.java:117)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraph.<init>(AtlasJanusGraph.java:93)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraphDatabase.getGraphInstance(AtlasJanusGraphDatabase.java:117)
>>>
>>>         at
>>> org.apache.atlas.repository.graphdb.janus.AtlasJanusGraph.<init>(AtlasJanusGraph.java:93)
>>>
>>>
>>>
>>>
>>>
>>> Any help is greatly appreciated..
>>>
>>>
>>>
>>>
>>>
>>> Mahender
>>>
>>>         at org.a
>>>
>>>
>>>
>>> On Tue, Oct 9, 2018 at 3:09 PM Madhan Neethiraj <madhan@apache.org>
>>> wrote:
>>>
>>> Mahender,
>>>
>>>
>>>
>>> “port 80”? Atlas should be listening in port 21000 by default. Which URL
>>> are you getting this error for?
>>>
>>>
>>>
>>> Thanks,
>>>
>>> Madhan
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> *From: *Shankesi Mahender <shankesi@gmail.com>
>>> *Date: *Tuesday, October 9, 2018 at 11:56 AM
>>> *To: *"madhan@apache.org" <madhan@apache.org>
>>> *Subject: *Re: Need Help!!! Atlas Installation Error
>>>
>>>
>>>
>>> Thanks Madhan..
>>>
>>>
>>>
>>> When I tried to run the curl command with admin:admin I got below error.
>>>
>>>
>>>
>>> curl: (7) Failed to connect to ipaddress port 80: Connection refused
>>>
>>>
>>>
>>> When I tried to start atlas_start.py I got the following error
>>>
>>>
>>>
>>>   File "atlas_start.py", line 107
>>>
>>>     print "Cannot run setup when server is running."
>>>
>>>                                                    ^
>>>
>>> SyntaxError: Missing parentheses in call to 'print'
>>>
>>>
>>>
>>> Do you know anything about this?
>>>
>>>
>>>
>>> Thanks for your help.
>>>
>>>
>>>
>>> Mahender
>>>
>>>
>>>
>>> On Tue, Oct 9, 2018 at 2:07 PM Madhan Neethiraj <madhan@apache.org>
>>> wrote:
>>>
>>> Mahender,
>>>
>>>
>>>
>>> Default username:password is: admin:admin. Please try with these and let
>>> me know.
>>>
>>>
>>>
>>> Thanks,
>>>
>>> Madhan
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> *From: *Shankesi Mahender <shankesi@gmail.com>
>>> *Date: *Tuesday, October 9, 2018 at 6:03 AM
>>> *To: *Shankesi Mahender <shankesi@gmail.com>
>>> *Subject: *Need Help!!! Atlas Installation Error
>>>
>>>
>>>
>>> I’m trying to install Apache Atlas on my Hdinsight cluster and following
>>> the instructions from the below page.
>>>
>>>
>>>
>>> https://atlas.apache.org/InstallationSteps.html
>>>
>>>
>>>
>>> I was able to install correctly until the below point.
>>>
>>>
>>>
>>> curl -u username:password http://localhost:21000/api/atlas/admin/version
>>>
>>>
>>>
>>> When I execute this command it is throwing an error, I have replace the
>>> localhost with my azure hdinsight one and error says
>>>
>>> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
>>>
>>> <title>403 - Forbidden: Access is denied.</title>
>>>
>>> <style type="text/css">
>>>
>>>
>>>
>>> I’m not sure what should I provide for username and password, I tried
>>> different ways username:password, admin:admin and my cluster id/password
>>> none of them seems to be working.
>>>
>>>
>>>
>>> Do you know any default userid and password is there for the
>>> installation? I didn’t see  anywhere in the documentation.
>>>
>>>
>>>
>>> Thanks for your help in advance.
>>>
>>>
>>>
>>> Mahender
>>>
>>>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message