atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Madhan Neethiraj (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ATLAS-2091) Search using entity and trait attributes - "#" in string attribute filter doesn't fetch results
Date Thu, 17 May 2018 03:37:00 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-2091?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Madhan Neethiraj updated ATLAS-2091:
------------------------------------
    Fix Version/s: 0.8.2
                   1.0.0

> Search using entity and trait attributes - "#" in string attribute filter doesn't fetch
results
> -----------------------------------------------------------------------------------------------
>
>                 Key: ATLAS-2091
>                 URL: https://issues.apache.org/jira/browse/ATLAS-2091
>             Project: Atlas
>          Issue Type: Sub-task
>          Components:  atlas-core
>    Affects Versions: 1.0.0
>            Reporter: Sharmadha Sainath
>            Assignee: Apoorv Naik
>            Priority: Major
>             Fix For: 0.8.2, 1.0.0
>
>         Attachments: 0001-ATLAS-2091-Attribute-values-containing-Tokenizer-cha.patch
>
>
> 1. Created an hdfs_path entity with owner name = "user#3"
> 2. Fired basic search with type name = hdfs_path and filter - owner = user#3. hdfs_path
entity was returned.
> 3. Fired basic search with type name = hdfs_path and filter - owner contains user#3.
No entity is returned.
> Other than "=" , operators like != , contains , ends_with , begins_with are not fetching
expected results due to # in search filter key.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message