atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Madhan Neethiraj <mad...@apache.org>
Subject Re: Dependent component versions for 1.0 release
Date Wed, 25 Apr 2018 15:17:03 GMT
Mandy,

What is the Spring version to target?

Thanks,
Madhan




´╗┐On 4/25/18, 1:36 AM, "Mandy Chessell" <mandy_chessell@uk.ibm.com> wrote:

    Dear all,
    I think we should move to the latest level of the spring framework/boot
    
    All the best
    Mandy
    ___________________________________________
    Mandy Chessell CBE FREng CEng FBCS
    IBM Distinguished Engineer
    
    Master Inventor
    Member of the IBM Academy of Technology
    Visiting Professor, Department of Computer Science, University of 
    Sheffield
    
    Email: mandy_chessell@uk.ibm.com
    LinkedIn: http://www.linkedin.com/pub/mandy-chessell/22/897/a49
    
    Assistant: Janet Brooks - jsbrooks12@uk.ibm.com
    
    
    
    From:   Nigel Jones <nigel.l.jones@gmail.com>
    To:     <dev@atlas.apache.org>
    Date:   24/04/2018 17:01
    Subject:        Re: Dependent component versions for 1.0 release
    
    
    
    
    
    On 2018/04/24 13:04:59, Graham Wallis <graham_wallis@uk.ibm.com> wrote: 
    
    > Do we need to include anything about development versions including 
    Maven, 
    > Java, etc?
    
    I think it would be worth mentioning in readme/ wiki build, though now we 
    have the maven-enforcer in place we know the min prereq java is java 8 
    update 151 & maven 3.5.0 which aren't far off (latest 172 - jdk 11/18.10 
    is next lts and could be 'interesting', and maven 3.5.3)
    
    Post-release I think there's a few other questions about specific 
    component versions (and pom standardization where it makes sense), but I 
    wouldn't change anything close to release
    
    
    
    



Mime
View raw message