atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruchi Solani <ruchi.sol...@freestoneinfotech.com>
Subject Re: Review Request 65813: ATLAS-2462 Sqoop import for all tables throws NPE for no table provided in command
Date Fri, 23 Mar 2018 11:50:54 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65813/
-----------------------------------------------------------

(Updated March 23, 2018, 11:50 a.m.)


Review request for atlas and Madhan Neethiraj.


Bugs: ATLAS-2462
    https://issues.apache.org/jira/browse/ATLAS-2462


Repository: atlas


Description
-------

When tried importing a specific table with below command there is no error:

sqoop import --connect jdbc:mysql://localhost/test --table testtable221 --hive-import --hive-database
sqoopimport023 --hive-table hivetesttable221 --username root -P -m 1 --fetch-size 1

When tried to import all tables from a specific database using below command, got NP error:

sqoop import-all-tables --connect jdbc:mysql://localhost/test --hive-import --hive-database
sqoopimport022 --username root -P -m 1 --fetch-size 1


Diffs (updated)
-----

  addons/sqoop-bridge/src/main/java/org/apache/atlas/sqoop/hook/SqoopHook.java 9e43430 


Diff: https://reviews.apache.org/r/65813/diff/3/

Changes: https://reviews.apache.org/r/65813/diff/2-3/


Testing
-------

sanity testing done.


Thanks,

Ruchi Solani


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message