atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sarath Subramanian <sar...@apache.org>
Subject Re: Deletion of relationships
Date Wed, 14 Feb 2018 19:05:43 GMT
Pierre,

Yes, that is a bug. We have changed guid to relationshipGuid. I have made
the fix as part of another patch I'm working on. Will get this fixed
shortly.

Thanks for catching this.


Thanks,
Sarath Subramanian

On Wed, Feb 14, 2018 at 7:12 AM, Pierre Padovani <
pierre.padovani@civitaslearning.com> wrote:

> Hey folks.. I'm playing with the latest master, and I ran across something
> I just don't get. According to the code, delete of relationships is
> supported as long as you have the guid of the relationship. When I create a
> simple setup of a hive_table as an input to a Process, and retrieve it I
> get something that looks like this:
>
> {
>     "referredEntities": {},
>     "entity": {
>         "typeName": "Process",
>         "attributes": {
>             "owner": null,
>             "outputs": null,
>             "qualifiedName": "p1",
>             "inputs": [
>                 {
>                     "guid": "eb0734a0-fe08-42fe-97ee-860c822571bc",
>                     "typeName": "hbase_table"
>                 }
>             ],
>             "name": "p1",
>             "description": null
>         },
>         "guid": "241347a7-5051-4919-8892-b2a2cb25e785",
>         "status": "ACTIVE",
>         "createdBy": "admin",
>         "updatedBy": "admin",
>         "createTime": 1518560480743,
>         "updateTime": 1518560494636,
>         "version": 0,
>         "relationshipAttributes": {
>             "outputs": [],
>             "knownLocations": [],
>             "externalReferences": [],
>             "notes": [],
>             "comments": [],
>             "inputs": [
>                 {
>                     "guid": "eb0734a0-fe08-42fe-97ee-860c822571bc",
>                     "typeName": "hbase_table",
>                     "displayText": "t1",
>                     "relationshipAttributes": {
>                         "typeName": "dataset_process_inputs"
>                     }
>                 }
>             ],
>             "relatedEntity": null,
>             "consumedBy": [],
>             "meanings": [],
>             "alsoKnownAs": [],
>             "tags": [],
>             "embeddedMetadata": [],
>             "contributor": [],
>             "starRatings": [],
>             "managedResources": [],
>             "meetings": [],
>             "todos": [],
>             "likes": []
>         },
>         "classifications": []
>     }
> }
>
> The relationship has no guid, and therefore I cannot directly access it to
> delete it. I know the guid was there in a previous build off of master, but
> it seems to have vanished.
>
> Ideas?
>
> Thanks!
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message