atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nigel Jones"<nigel.l.jo...@gmail.com>
Subject Java 8 & maven 3.5.0 dependency
Date Wed, 01 Nov 2017 16:02:41 GMT
I've proposed a patch in ATLAS-2245 that would ENFORCE
 - java 8 or above - since master now requires it
 - Maven 3.5.0 or above  - after some maven issues, jenkins is now at this same version -
though current is 3.5.2

Details are in the JIRA, but the consequence is that if the patch is applied or submitted,
anyone with earlier levels of java (less likely), or maven (pretty likely) WILL FAIL TO BUILD.

Please add any comments to the jira or review board patch. I think we should enforce what
we 
believe we need, in order to maintain consistency. There may be places in the wiki/docs we
also wish to clarify the current environment dependencies.

Nigel.

Mime
View raw message