atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nigel Jones <jon...@uk.ibm.com>
Subject Re: Review Request 64141: [ATLAS-2287]: Include lucene libraries when building atlas distribution with Janus profile
Date Thu, 30 Nov 2017 14:52:41 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/64141/#review192257
-----------------------------------------------------------



I tried this patch on atlas-master (0900 UTC 20171130), maven 3.5.0, java 8 (b152), macOS.

Only built for janus
Built clean.  
Server started, but seemed very slow to do so 
application.log showing many errors - including zookeeper every 1s 
quick_start failed (503/service unavailable) 
UI fails (503/service unavailable) 
script for titan054 etc on mail list did pass the above (some errors, but many less) 
Conclusion: patch doesn't work for me  - Nigel Jones

- Nigel Jones


On Nov. 29, 2017, 2:32 a.m., Sarath Subramanian wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/64141/
> -----------------------------------------------------------
> 
> (Updated Nov. 29, 2017, 2:32 a.m.)
> 
> 
> Review request for atlas, Apoorv Naik, Ashutosh Mestry, and Madhan Neethiraj.
> 
> 
> Bugs: ATLAS-2287
>     https://issues.apache.org/jira/browse/ATLAS-2287
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> When Atlas is build using -Pdist profile, lucene jars are excluded during packaging of
the war file. Since we are not shading graphdb module for janus profile, these jars are needed
as run time dependency.
> Titan's shaded jar includes the lucene libraries and hence were excluded during packaging
of war to avoid duplicate dependencies.
> 
> 
> Diffs
> -----
> 
>   distro/pom.xml eea256d8 
>   pom.xml 3720c1f5 
>   webapp/pom.xml b4a96d36 
> 
> 
> Diff: https://reviews.apache.org/r/64141/diff/1/
> 
> 
> Testing
> -------
> 
> validated building atlas distribution using both janus and titan0 profile. Atlas starts
fine and basic functionalities working.
> 
> mvn clean install -DskipTests -Pdist,embedded-hbase-solr
> mvn clean install -DskipTests -Pdist,embedded-hbase-solr -DGRAPH-PROVIDER=titan0
> 
> 
> Thanks,
> 
> Sarath Subramanian
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message