atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keval Bhatt (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ATLAS-2171) Error in constructing base path for UI API when accessing Atlas via knox proxy without "/" at the end
Date Mon, 09 Oct 2017 08:55:00 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-2171?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Keval Bhatt updated ATLAS-2171:
-------------------------------
    Description: 
1. Enabled knox proxy for atlas.
2.Accessed Atlas UI via proxy using https://knox_gateway:8443/gateway/ui/atlas
3. Provided admin username and password and logged into Atlas
4. Now, opened another tab in browser with URL
{code}
https://knox_gateway:8443/gateway/ui/atlas
{code}

UI is loaded without data because API path is not formed properly.

If the URL is accessed with "/" at the end, logs in as admin user and all operations work
fine.
Example :
{code}
https://knox_gateway:8443/gateway/ui/atlas/
{code}



  was:
1. Enabled knox proxy for atlas.
2.Accessed Atlas UI via proxy using https://knox_gateway:8443/gateway/ui/atlas
3. Provided admin username and password and logged into Atlas
4. Now, opened another tab in browser with URL
{code}
https://knox_gateway:8443/gateway/ui/atlas
{code}
I was not logged in as admin but as an unknown user.No read/write operations were allowed.
Found the following application logs :
{code}
2017-09-26 05:39:31,467 ERROR - [pool-2-thread-9:] ~ Unable to find Atlas Resource corresponding
to :
Setting UNKNOWN (AtlasAuthorizationUtils:143)
{code}

If the URL is accessed with "/" at the end , logs in as admin user and all operations work
fine.
Example :
{code}
https://knox_gateway:8443/gateway/ui/atlas/
{code}




> Error in constructing base path for UI API when accessing Atlas via knox proxy without
"/" at the end
> -----------------------------------------------------------------------------------------------------
>
>                 Key: ATLAS-2171
>                 URL: https://issues.apache.org/jira/browse/ATLAS-2171
>             Project: Atlas
>          Issue Type: Bug
>          Components:  atlas-core
>    Affects Versions: 1.0.0
>            Reporter: Sharmadha Sainath
>            Assignee: Keval Bhatt
>            Priority: Critical
>
> 1. Enabled knox proxy for atlas.
> 2.Accessed Atlas UI via proxy using https://knox_gateway:8443/gateway/ui/atlas
> 3. Provided admin username and password and logged into Atlas
> 4. Now, opened another tab in browser with URL
> {code}
> https://knox_gateway:8443/gateway/ui/atlas
> {code}
> UI is loaded without data because API path is not formed properly.
> If the URL is accessed with "/" at the end, logs in as admin user and all operations
work fine.
> Example :
> {code}
> https://knox_gateway:8443/gateway/ui/atlas/
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message