atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Madhan Neethiraj (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ATLAS-2061) Regression : Entity,Tag filter fetches empty results when applied on an enum attribute.
Date Wed, 20 Sep 2017 04:37:00 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-2061?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Madhan Neethiraj updated ATLAS-2061:
------------------------------------
    Issue Type: Sub-task  (was: Bug)
        Parent: ATLAS-1822

> Regression : Entity,Tag filter fetches empty results when applied on an enum attribute.
> ---------------------------------------------------------------------------------------
>
>                 Key: ATLAS-2061
>                 URL: https://issues.apache.org/jira/browse/ATLAS-2061
>             Project: Atlas
>          Issue Type: Sub-task
>          Components:  atlas-core
>    Affects Versions: 0.9-incubating
>            Reporter: Sharmadha Sainath
>            Assignee: Apoorv Naik
>            Priority: Blocker
>             Fix For: 0.9-incubating, 0.8.1-incubating
>
>         Attachments: 0001-ATLAS-2061-Entity-Tag-filter-fetches-empty-results-w.patch
>
>
> 1.Created a tag with an attribute fileAction of type file_action.
> 2.Associated the tag to an entity with fileAction value "EXECUTE"
> 3.Fired a basic query with classification = <tagname> and tag filter : fileAction
= EXECUTE.  The entity was not fetched.
> No results are fetched with "!=" operator too on values other than EXECUTE like WRITE
, READ etc.,
> Hence , enum filtering is not fetching results. 
> This is a regression , as few commits back,  enum filtering was working as expected.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message