atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apoorv Naik <naik.apo...@gmail.com>
Subject Re: Review Request 61234: Invalid attribute during entity update should throw 400
Date Sat, 29 Jul 2017 00:08:51 GMT


> On July 28, 2017, 11:52 p.m., Madhan Neethiraj wrote:
> > repository/src/main/java/org/apache/atlas/repository/store/graph/v1/EntityGraphMapper.java
> > Lines 261 (patched)
> > <https://reviews.apache.org/r/61234/diff/1/?file=1785405#file1785405line261>
> >
> >     Having a tolerant behvior, of ignoring unknown attributes, would be helpful.
If V1 APIs rejected unknown attributes earlier, I would suggest to move this error only in
V1 path.

Will do.


- Apoorv


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/61234/#review181745
-----------------------------------------------------------


On July 28, 2017, 9:47 p.m., Apoorv Naik wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/61234/
> -----------------------------------------------------------
> 
> (Updated July 28, 2017, 9:47 p.m.)
> 
> 
> Review request for atlas and Madhan Neethiraj.
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> Right now in the V2 API, if an entity update is performed with an invalid attribute it's
ignored and the entity gets updated
> 
> 
> Diffs
> -----
> 
>   repository/src/main/java/org/apache/atlas/repository/store/graph/v1/EntityGraphMapper.java
b8fd70e5 
> 
> 
> Diff: https://reviews.apache.org/r/61234/diff/1/
> 
> 
> Testing
> -------
> 
> Update JSON (POST on entity) with invalid attribute in the request results in 400
> 
> mvn clean package executes successfully
> 
> 
> Thanks,
> 
> Apoorv Naik
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message