atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Madhan Neethiraj (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-1885) DELETE classification causes error message
Date Sun, 18 Jun 2017 05:50:00 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-1885?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16053076#comment-16053076
] 

Madhan Neethiraj commented on ATLAS-1885:
-----------------------------------------

[~LauraNgo] - this issue looks to be a duplicate of ATLAS-1673, which has been fixed in master
and 0.8-incubting branches. But the fix is not present in 0.8-incubating release. Can you
try on the latest in 0.8-incubating branch or master branch?

> DELETE classification causes error message
> ------------------------------------------
>
>                 Key: ATLAS-1885
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1885
>             Project: Atlas
>          Issue Type: Bug
>          Components:  atlas-core
>    Affects Versions: 0.8-incubating
>            Reporter: Laura Ngo
>
> * Created classification via POST (/v2/types/typedefs)
> * Tried to delete it via DELETE (/v2/types/typedefs)
> * Get 204 no content response (should have been removed)
> * Go to UI tag is still there
> * Get error in UI
> Discovery query failed g.V().has('__traitNames', T.in, traitNames) [startIdx..<endIdx].toList()
> {code}
> {
>  "classificationDefs": [{
>   "name": "test_classification_10",
>   "superTypes": [],
>   "attributeDefs": []
>  }],
>  "entityDefs": [],
>  "enumDefs": [],
>  "structDefs": []
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message