atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Laura Ngo (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ATLAS-1885) DELETE classification causes error message
Date Sat, 17 Jun 2017 22:25:00 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-1885?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16053011#comment-16053011
] 

Laura Ngo edited comment on ATLAS-1885 at 6/17/17 10:24 PM:
------------------------------------------------------------

The refresh button seems not to work.  I think the presence of the error stops the refresh.

Refreshing the webpage, hard refresh of the web page and a different browser make no difference.
But after stopping and restarting the Atlas service the error disappears, the classification
is deleted and the classification is removed from the UI.

The classification is also still there when I use GET http://127.0.0.1:21000/api/atlas/v2/types/typedef/name/{name}

It is only removed when I restart the Atlas service.

The error is 'Discovery query failed g.V().has('__traitNames', T.in, traitNames) [startIdx..<endIdx].toList()'.


was (Author: laurango):
The refresh button seems not to work.  I think the presence of the error stops the refresh.

Refreshing the webpage, hard refresh of the web page and a different browser make no difference.
But after stopping and restarting the Atlas service the error disappears, the classification
is deleted and the classification is removed from the UI.

The classification is also still there when I use GET http://127.0.0.1:21000/api/atlas/v2/types/typedef/name/{name}.
It is only removed when I restart the Atlas service.

The error is 'Discovery query failed g.V().has('__traitNames', T.in, traitNames) [startIdx..<endIdx].toList()'.

> DELETE classification causes error message
> ------------------------------------------
>
>                 Key: ATLAS-1885
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1885
>             Project: Atlas
>          Issue Type: Bug
>          Components:  atlas-core
>    Affects Versions: 0.8-incubating
>            Reporter: Laura Ngo
>
> * Created classification via POST (/v2/types/typedefs)
> * Tried to delete it via DELETE (/v2/types/typedefs)
> * Get 204 no content response (should have been removed)
> * Go to UI tag is still there
> * Get error in UI
> Discovery query failed g.V().has('__traitNames', T.in, traitNames) [startIdx..<endIdx].toList()
> {code}
> {
>  "classificationDefs": [{
>   "name": "test_classification_10",
>   "superTypes": [],
>   "attributeDefs": []
>  }],
>  "entityDefs": [],
>  "enumDefs": [],
>  "structDefs": []
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message