atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xinzhi,Luo (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ATLAS-1824) Cannot create hive lineage when using query "insert into table X select A.Y, B.Z from A,B"
Date Tue, 20 Jun 2017 02:52:02 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-1824?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Xinzhi,Luo updated ATLAS-1824:
------------------------------
    Attachment:     (was: 0001-fix-ATLAS-1824.patch)

> Cannot create hive lineage when using query "insert into table X select A.Y, B.Z from
A,B"
> ------------------------------------------------------------------------------------------
>
>                 Key: ATLAS-1824
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1824
>             Project: Atlas
>          Issue Type: Bug
>          Components:  atlas-core
>    Affects Versions: trunk, 0.7-incubating, 0.8-incubating, 0.7.1-incubating, 0.9-incubating,
0.8.1-incubating
>            Reporter: qinglin,xia
>            Assignee: Xinzhi,Luo
>              Labels: atlas
>             Fix For: 0.9-incubating
>
>         Attachments: 0001-fix-ATLAS-1824.patch, failed_lineage_input_output.png, failed_lineage.png
>
>
> Problem: 
> I am using atlas to create hive lineage, I found that when using the hive query "insert
into table A select B.name ,C.name from B, C", the lineage between A, B and C cannot be created.

> Steps to reproduce: 
> 1. log in to the hive shell
> 2. create hive table a, b,c and insert into data into a,b and c
> 3. using query "insert into table datalake_demo.d9 select a.id as key, a.id, a.aname
,b.bname,c.cname from datalake_demo.a,datalake_demo.b,datalake_demo.c where a.id = b.id and
b.id = c.id" to create hive table d9
> Expected Result:
> hive_process is created , input of the process is a, b, c, output of the process is datalake_demo.d9,
and the process could be shown on atlas UI
> Actual Result: 
> hive_process is created, input of the process is a, b, b, d9, output of the process is
null, and the process could not be shown on atlas UI, according to the attached pic "failed_lineage.png"
and "failed_lineage_input_output.png"
> PS: We are working on fixing the issue!



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message