atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sharmadha Sainath (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ATLAS-1730) Error after updating attribute's data type of an Atlas type
Date Mon, 10 Apr 2017 19:46:41 GMT
Sharmadha Sainath created ATLAS-1730:
----------------------------------------

             Summary: Error after updating attribute's data type of an Atlas type 
                 Key: ATLAS-1730
                 URL: https://issues.apache.org/jira/browse/ATLAS-1730
             Project: Atlas
          Issue Type: Bug
          Components:  atlas-core
    Affects Versions: 0.8-incubating, 0.9-incubating
            Reporter: Sharmadha Sainath


1.Created a type with one of its attributes' type as date and POSTed the type definition to

{code}
/api/atlas/v2/types/typedefs
{code}
2. Tried to update the attribute data type to string , hence modified the JSON (changed "date"
to "string") and PUT the JSON to the same API which succeeded.
3. Tried to create an entity of the type and provided "val1" as value for the string attribute
(which was updated from date).
4. Entity creation failed with
{code}
java.lang.ClassCastException: java.lang.Long cannot be cast to java.lang.String
{code}

This could be a rare one but this scenario might cause issues when user initially gave data
type as "date" by mistake and wants to update it as "string". 
Also , since attribute delete is not allowed as part of type update , attribute with "date"
type can't be deleted and recreated with string.





--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message