atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashutosh Mestry <ames...@hortonworks.com>
Subject Re: Review Request 57800: ATLAS-1675: type-registry re-initialization failure when instance goes from passive to active state
Date Tue, 21 Mar 2017 18:20:23 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/57800/#review169594
-----------------------------------------------------------


Ship it!




Ship It!

- Ashutosh Mestry


On March 21, 2017, 8:46 a.m., Madhan Neethiraj wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/57800/
> -----------------------------------------------------------
> 
> (Updated March 21, 2017, 8:46 a.m.)
> 
> 
> Review request for atlas.
> 
> 
> Bugs: ATLAS-1675
>     https://issues.apache.org/jira/browse/ATLAS-1675
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> When an instance activates, its type-registry is initialzed from store contents. Since
the registry already had types loaded during its startup, this initialization failed with
'type already exists' error. Updated the initialization to clear the registry contents before
loading types from the store.
> 
> 
> Diffs
> -----
> 
>   intg/src/main/java/org/apache/atlas/type/AtlasTypeRegistry.java ddb6c71 
>   repository/src/main/java/org/apache/atlas/repository/store/graph/AtlasTypeDefGraphStore.java
c3b6d20 
> 
> 
> Diff: https://reviews.apache.org/r/57800/diff/1/
> 
> 
> Testing
> -------
> 
> Verified that in HA mode, instance activation completes successfully
> 
> 
> Thanks,
> 
> Madhan Neethiraj
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message