atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Hagelberg (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-1588) ExportService is not compatible with Tinkerpop 3
Date Wed, 22 Feb 2017 21:45:44 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-1588?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15879308#comment-15879308
] 

Jeffrey Hagelberg commented on ATLAS-1588:
------------------------------------------

[~ashustariov] - If you could address it, that would be good.  We're in the process of doing
final testing of both the titan1 and ibm-graph implementations of the graph abstraction layer,
which both use TP 3.  Hopefully those will be committed fairly soon.  Until this is done,
the ExportService won't be usable with either of those backends.  Using GremlinExpressionFactory.INSTANCE
seems to be a good choice since it already has logic for generating gremlin that works with
TP2 or TP3.  A lot of the logic in there is geared towards what the DSL translator needs,
though.  There might need to be some refactoring needed, for example a method to create a
has expression that does not require a FieldInfo and GraphPersistenceStrategies object to
be on hand :-)

> ExportService is not compatible with Tinkerpop 3
> ------------------------------------------------
>
>                 Key: ATLAS-1588
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1588
>             Project: Atlas
>          Issue Type: Bug
>            Reporter: Jeffrey Hagelberg
>
> The ExportService needs to be changed to generate gremlin using GremlinExpressionFactory
so that it works with backends that require TinkerPop 3.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message