atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ismaël Mejía <ieme...@gmail.com>
Subject Re: Fw: [VOTE] Release Apache Atlas 0.7.1 (incubating) - release candidate 2 (dev group vote)
Date Wed, 18 Jan 2017 15:07:52 GMT
+1 (non-binding)

All signatures/SHAs ok.

The UI issue (breadcrumbs) broke on 0.7.0 works well in version 0.7.1.

I had one test breaking on Atlas Web Application, and the build process was
a bit messy, for more
details:

1. I tried first:

    mvn clean package -Pdist,embedded-hbase-solr -DskipTests

2. and it broke, so I followed the instructions :)

    export MAVEN_OPTS="-Xmx1536m -XX:MaxPermSize=512m" && mvn clean install

It broke in this test:

Results :

Failed tests:
  EntityJerseyResourceIT.testDeleteExistentTraitNonExistentForEntity:696 »
JSON ...

Tests run: 81, Failures: 1, Errors: 0, Skipped: 0

3. So I retried to produce the distribution to test the UI issue with the
same
   command in (1) and it worked perfectly.

I think that apart of the test, there is some issue with the dependencies
order that didn't let me build the binary distribution without doing
the maven install.

Note I tested on Ubuntu Linux 16.04 (x64) with Oracle Jdk 8.

Ismaël Mejía


On Wed, Jan 18, 2017 at 2:12 PM, Jean-Baptiste Onofré <jb@nanthrax.net>
wrote:

> +1
>
>
> Checked the build, legal/headers, signatures.
>
> Regards
> JB
>
>
> On 01/18/2017 05:09 AM, Keval Bhatt wrote:
>
>> Hi,
>>
>> Verified the build from apache-atlas-0.7.1-incubating-sources.tar.gz
>> <https://dist.apache.org/repos/dist/dev/incubator/atlas/0.7.
>> 1-incubating-rc2/apache-atlas-0.7.1-incubating-sources.tar.gz>
>>
>>
>> Checksum is fine.
>> Build was successful.
>> Added test data from quickstart script
>> Verified the UI and all the basic UI functionality is working fine.
>>
>> +1
>>
>> Thanks
>> Keval
>>
>>
>>
>>
>> On Wed, Jan 18, 2017 at 4:48 PM, David Radley <david_radley@uk.ibm.com>
>> wrote:
>>
>> Atlas team,
>>> I am not sure if the resdme updates have gone in; from the link below the
>>> readme seems not to be correct.
>>>
>>>
>>> I have downloaded the tar.gz file.
>>>
>>>
>>> Readme feedback
>>> 1) I notice the readme starts by saying to get the code using "git clone
>>> https://github.com/apache/incubator-atlas.git"
>>> This is the wrong git command - as this will put the code into git - not
>>> clone it from the repository into a local folder.
>>>
>>> I look on http://atlas.incubator.apache.org/InstallationSteps.html. It
>>> says to use "git clone
>>> https://git-wip-us.apache.org/repos/asf/incubator-atlas.git atlas"
>>> We need to document a 0.7.1 equivalent for the clone in the readme.
>>>
>>> 2) I think that the readme should explicitly mention the version number
>>> 0.7.1 and also point to the latest code 0.8 and explicitly talk about the
>>> need for 0.7.1, rather than using 0.8, which I assume is primarily the
>>> java level. I think all the urls should default to the latest code (0.8).
>>>
>>>
>>> 3) I suggest that the readme includes the versions of any libraries that
>>> need to be on a machine to be able to build. I would mention the required
>>> levels of Java, Maven, Git and Python. I have not installed as I was not
>>> sure of the levels I need of these prereqs.
>>>
>>> The vote will be open for at least 72 hours or until necessary votes are
>>> reached.
>>> [ ] +1  approve
>>> [ ] +0  no opinion
>>> [ ] -1  disapprove (and reason why)
>>>
>>> Here is my +1, as long as we address the above points.
>>>
>>> Thanks,
>>> David
>>>
>>>
>>>
>>>
>>> Unless stated otherwise above:
>>> IBM United Kingdom Limited - Registered in England and Wales with number
>>> 741598.
>>> Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6
>>> 3AU
>>>
>>>
>>
> --
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message