atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Halliday (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ATLAS-1263) setup fails because server id not set
Date Wed, 02 Nov 2016 13:10:59 GMT
Jonathan Halliday created ATLAS-1263:
----------------------------------------

             Summary: setup fails because server id not set
                 Key: ATLAS-1263
                 URL: https://issues.apache.org/jira/browse/ATLAS-1263
             Project: Atlas
          Issue Type: Bug
            Reporter: Jonathan Halliday


When running 'bin/atlas_start.py -setup' the process fails with java.lang.NumberFormatException:
null as the default config doesn't set a server id (required for HA only)

org.apache.atlas.ha.AtlasServerIdSelector.selectServerId(AtlasServerIdSelector.java:51)
	at org.apache.atlas.web.setup.SetupSteps.getServerId(SetupSteps.java:138)
	at org.apache.atlas.web.setup.SetupSteps.createSetupInProgressNode(SetupSteps.java:150)
	at org.apache.atlas.web.setup.SetupSteps.handleSetupInProgress(SetupSteps.java:96)
	at org.apache.atlas.web.setup.SetupSteps.runSetup(SetupSteps.java:72)

The exception handling in SetupSteps.getServerId should catch NumberFormatException in addition
to AtlasException, or AtlasServerIdSelector.selectServerId should catch and wrap it in AtlasException.
 Additionally there should be test coverage for the setup process.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message