atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nigel Jones (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-1218) Atlas says it is started but does not accept REST requests
Date Mon, 10 Oct 2016 13:58:20 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-1218?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15562387#comment-15562387
] 

Nigel Jones commented on ATLAS-1218:
------------------------------------

I like this suggestion. 

I was setting up Cassandra to run under docker using docker-compose, and hit a similar issue
whereby I wanted the client to wait until the server was ready. I ended up using a script
that polled the relevant port. 

We may be able to do better in the atlas startup script with a check knowledgeable of atlas,
but if not the one I used was at https://github.com/vishnubob/wait-for-it . That could also
be useful in a similar situation. Indeed we could maybe have a "wait for atlas" or "is atlas
running" script too as they can also help with automation. One less job for the integrator
to do?

> Atlas says it is started but does not accept REST requests
> ----------------------------------------------------------
>
>                 Key: ATLAS-1218
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1218
>             Project: Atlas
>          Issue Type: Bug
>            Reporter: David Radley
>
> I start Atlas on the command line and it tells me is started - but REST requests are
not accepted immediately. There appears to be asynchronous background processes that have
not yet initialized. I feel that when Atlas says it is started it should be open for business
and accept REST requests.  a few seconds later REST requests are accepted. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message