atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apoorv Naik (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ATLAS-1144) After updating/creating a set of entities, response contains the first entity definition only
Date Wed, 31 Aug 2016 19:27:20 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-1144?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Apoorv Naik updated ATLAS-1144:
-------------------------------
    Attachment: ATLAS_1144.patch

Latest patch

> After updating/creating a set of entities, response contains the first entity definition
only
> ---------------------------------------------------------------------------------------------
>
>                 Key: ATLAS-1144
>                 URL: https://issues.apache.org/jira/browse/ATLAS-1144
>             Project: Atlas
>          Issue Type: Bug
>    Affects Versions: 0.7-incubating
>            Reporter: Apoorv Naik
>             Fix For: 0.7-incubating
>
>         Attachments: ATLAS_1144.patch
>
>
> Version: Atlas 0.7
> Steps to recreate:
> Create two entities (POST /entities) and note guid1 and guid2 that get generated.
> Update these entities in the same PUT /entities and response contains (truncated for
convenience):
> {
>   "requestId": "...",
>   "GUID": [
>     "guid1",
>     "guid2"
>   ],
>   "definition": "{......*\"id\":\"guid1\"*,....}
> }
> {color:red}Issue: definition does not contain the data for second entity.{color}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message