atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Madhan Neethiraj <mad...@apache.org>
Subject Re: Review Request 49440: ATLAS-963 : UI: Entity details is not display String array attribute values correctly
Date Wed, 06 Jul 2016 07:03:59 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/49440/#review140960
-----------------------------------------------------------


Ship it!




Ship It!

- Madhan Neethiraj


On June 30, 2016, 12:53 p.m., keval bhatt wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/49440/
> -----------------------------------------------------------
> 
> (Updated June 30, 2016, 12:53 p.m.)
> 
> 
> Review request for atlas, Gautam Borad, Madhan Neethiraj, Shwetha GS, and Hemanth Yamijala.
> 
> 
> Bugs: ATLAS-963
>     https://issues.apache.org/jira/browse/ATLAS-963
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> If an entity definition contains an attribute that is a JSON array of strings, the UI
is not rendering this properly.
> The attribute value will be of type:
>  
> attribute_name: [ value1, value2, ... ] 
> For example:
>  
> "columnNames":[ "cssnsi", "mylookca" ] 
> The same issue may be there for other types of array attribute values like array of ints,
booleans etc.
> 
> 
> Diffs
> -----
> 
>   dashboardv2/public/js/utils/CommonViewFunction.js d699fe8 
> 
> Diff: https://reviews.apache.org/r/49440/diff/
> 
> 
> Testing
> -------
> 
> Tested following array in asset details property table: and its workd fine.
> 
>  'columnNames':[ "cssnsi", "mylookca" ,true,10,{parent-1:true,parent-2:{"child":"true"}}]
> 
> 
> Thanks,
> 
> keval bhatt
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message