atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hemanth Yamijala <hyamij...@hortonworks.com>
Subject Re: authentication with v0.7
Date Thu, 07 Jul 2016 03:42:35 GMT
Hi Herman,

Sorry, it is not possible to use Apache Atlas 0.7 without an authentication mode. The simplest
authentication setup is file based authentication the details of which are documented here:
http://atlas.incubator.apache.org/Authentication-Authorization.html

To use the 0.7 server, you would need to use the 0.7 version of the Atlas client. With it,
you can look at the QuickStart example to see how authentication is implemented in the client
library.

https://github.com/apache/incubator-atlas/blob/0.7-incubating/webapp/src/main/java/org/apache/atlas/examples/QuickStart.java

Specifically, this constructor of AtlasClient: https://github.com/apache/incubator-atlas/blob/0.7-incubating/client/src/main/java/org/apache/atlas/AtlasClient.java#L144

Hope this helps.

Thanks
Hemanth
________________________________________
From: Herman Yu <herman.yu@teeupdata.com>
Sent: Wednesday, July 06, 2016 8:07 PM
To: dev@atlas.incubator.apache.org
Subject: authentication with v0.7

Hi,

Is there a way to disable authentication with v0.7 (no login page with UI and REST calls doesn’t
require U/P)? We are testing codes (uses atlasClient)  built for v0.5 on v0.7 on a sandbox
environment, it fails with authentication. v0.7 is configured using simple file based authentication.

I tried set all authentication.method to false in atlas-application.properties, it seems still
default to simple, UI still displays login page and REST calls still failed with authentication
failure.

if not, where is the best place to find changes required to atlasClient based codes to make
it work with authentication?

Thanks
Herman.



Mime
View raw message