atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ATLAS-928) UI is not showing the name column for hive tables in the schema tab
Date Tue, 21 Jun 2016 09:49:58 GMT

     [ https://issues.apache.org/jira/browse/ATLAS-928?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hemanth Yamijala updated ATLAS-928:
-----------------------------------
    Fix Version/s: 0.7-incubating

> UI is not showing the name column for hive tables in the schema tab
> -------------------------------------------------------------------
>
>                 Key: ATLAS-928
>                 URL: https://issues.apache.org/jira/browse/ATLAS-928
>             Project: Atlas
>          Issue Type: Bug
>            Reporter: Hemanth Yamijala
>            Priority: Critical
>             Fix For: 0.7-incubating
>
>         Attachments: hive_schema_response.json
>
>
> * Create a hive table from the hive hook.
> * Search for it in the UI, and select the schema tab
> * There is no name shown for the columns of the table (although all other attributes
like comment, data type are present).
> The same issue does not occur for quick_start Tables.
> The reason seems to be that the UI is using the attributeDefinitions element in the return
of the schema API to decide what columns to show. With ATLAS-819, the name attribute was made
a common attribute via a supertype for assets like hive tables. The Schema API does not return
the super type attributes in the attributeDefinitions. Hence, even though the response of
the schema API contains the name attribute, because it is missing from the attributeDefinitions,
it is not picked up.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message