atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suma Shivaprasad (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ATLAS-542) Make qualifiedName and name consistent across all Datasets and Process
Date Fri, 10 Jun 2016 19:10:21 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-542?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15323854#comment-15323854
] 

Suma Shivaprasad edited comment on ATLAS-542 at 6/10/16 7:09 PM:
-----------------------------------------------------------------

Some comments:

* Certainly not related to this JIRA, and may already exist, but in the FS model, should we
also have a name which is the short name of a file. Would be really easy for search.

 --> Agreed. Have already incorporated those changes in fillHDFSDataset in HIveHook and
similarly in StormHook

* SqoopHookIT -  {{"%s as t where name = '%s',  db where " + AtlasClient.NAME + " = '%s' and
clusterName = '%s'" + " select t"}} - Please consider using the constant for all occurrences
of name.

--> Will fix .
* StormAtlasHook - {{dataSetReferenceable.set(AtlasClient.REFERENCEABLE_ATTRIBUTE_NAME, hiveTableName);}}
- Should be tableQualifiedName, right?

--> Thanks for catching this. Will Fix
* DefaultMetadataService - {{TypesUtil.createRequiredAttrDef("name", DataTypes.STRING_TYPE);}}
- Please use constant.

--> Will fix

This is a breaking change. So maybe we should call attention to this in the dev mailing list
- can you please send out a note?

--> Will send out a note. Thanks


was (Author: yhemanth):
Some comments:

* Certainly not related to this JIRA, and may already exist, but in the FS model, should we
also have a name which is the short name of a file. Would be really easy for search.
* SqoopHookIT -  {{"%s as t where name = '%s',  db where " + AtlasClient.NAME + " = '%s' and
clusterName = '%s'" + " select t"}} - Please consider using the constant for all occurrences
of name.
* StormAtlasHook - {{dataSetReferenceable.set(AtlasClient.REFERENCEABLE_ATTRIBUTE_NAME, hiveTableName);}}
- Should be tableQualifiedName, right?
* DefaultMetadataService - {{TypesUtil.createRequiredAttrDef("name", DataTypes.STRING_TYPE);}}
- Please use constant.

This is a breaking change. So maybe we should call attention to this in the dev mailing list
- can you please send out a note?

> Make qualifiedName and name consistent across all Datasets and Process
> ----------------------------------------------------------------------
>
>                 Key: ATLAS-542
>                 URL: https://issues.apache.org/jira/browse/ATLAS-542
>             Project: Atlas
>          Issue Type: Sub-task
>    Affects Versions: 0.7-incubating
>            Reporter: Suma Shivaprasad
>            Assignee: Suma Shivaprasad
>             Fix For: 0.7-incubating
>
>         Attachments: ATLAS-542.patch
>
>
> Currently hive_db, hive_column has qualifiedName holding the fully qualified Name and
name having the shorter name. 
> However hive_table has the fully qualified Name in "name" and shorter Name in tableName.
We should make this consistent for better search experience by removing tableName and keep
it consistent with db, column
> Same with hive_process, storm_topology, falcon_process - needs to have a qualifiedName




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message