atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shwetha G S (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-505) Create Entity response from API should match the data in ATLAS_ENTITIES kafka topic when some attributes are set to null
Date Tue, 14 Jun 2016 05:11:57 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15328952#comment-15328952
] 

Shwetha G S commented on ATLAS-505:
-----------------------------------

If we release this out now, we will have to support it for a long time. Hence I wanted to
take a look at it now to figure out the issue and scope of fix. Looking at input_output.txt,
the entity definition json is same, but the topic message has more fields like message type,
which I think is valid. So, will resolve this as not a problem

> Create Entity response from API should match the data in ATLAS_ENTITIES kafka topic when
some attributes are set to null
> ------------------------------------------------------------------------------------------------------------------------
>
>                 Key: ATLAS-505
>                 URL: https://issues.apache.org/jira/browse/ATLAS-505
>             Project: Atlas
>          Issue Type: Bug
>    Affects Versions: trunk
>            Reporter: Chethana
>            Priority: Critical
>             Fix For: 0.7-incubating
>
>         Attachments: Type.txt, input_output.txt
>
>
> create a type in atlas 
> create an entity of type
> Make sure this entity is pushed to atlas topic
> The response from create entity API and data pushed to kafka queue should match
> This could be possibly caused by different JSON libraries used between Notification and
API classes



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message