atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kantor <dkan...@us.ibm.com>
Subject Re: Review Request 48760: ATLAS-908: Force index creation up front
Date Wed, 15 Jun 2016 22:40:40 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/48760/#review137871
-----------------------------------------------------------


Ship it!




Ship It!

- David Kantor


On June 15, 2016, 10:35 p.m., Jeff Hagelberg wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/48760/
> -----------------------------------------------------------
> 
> (Updated June 15, 2016, 10:35 p.m.)
> 
> 
> Review request for atlas and David Kantor.
> 
> 
> Bugs: ATLAS-908
>     https://issues.apache.org/jira/browse/ATLAS-908
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> When starting Atlas for the first time, the graph indices do not actually get created
up front when starting Atlas. This is a problem because you can configure Titan to not allow
queries to run if there is not an graph index that can be used (using the for. In environments
like this, the Atlas startup fails because it attempts to restore the typesystem (which runs
a query) before creating the base graph indices.
> 
> 
> Diffs
> -----
> 
>   repository/src/main/java/org/apache/atlas/RepositoryMetadataModule.java c4c767827014a265471250306f35316a0b4ed67f

> 
> Diff: https://reviews.apache.org/r/48760/diff/
> 
> 
> Testing
> -------
> 
> Ran repository tests, no issues found.
> 
> 
> Thanks,
> 
> Jeff Hagelberg
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message