atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ATLAS-659) atlas_start fails on Windows
Date Tue, 12 Apr 2016 05:52:25 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-659?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15236629#comment-15236629
] 

Hemanth Yamijala edited comment on ATLAS-659 at 4/12/16 5:51 AM:
-----------------------------------------------------------------

While we should be more careful in future, one quick note is that it is quite easy to disable
this via configuration. I set the value of {{atlas.graph.storage.hostname}} to anything other
than localhost to disable this. (Even 127.0.0.1 works :-)). Of course, you would still need
a setup of HBase for Atlas to start.


was (Author: yhemanth):
While we should be more careful in future, one quick note is that it is quite easy to disable
this via configuration. I set the value of {{atlas.graph.storage.hostname}} to anything other
than localhost to disable this. (Even 127.0.0.1 works :-)).

> atlas_start fails on Windows
> ----------------------------
>
>                 Key: ATLAS-659
>                 URL: https://issues.apache.org/jira/browse/ATLAS-659
>             Project: Atlas
>          Issue Type: Bug
>            Reporter: David Kantor
>            Assignee: David Kantor
>            Priority: Blocker
>
> Recent changes for using HBase as the default storage backend has broken Atlas startup
on Windows, which now fails with:
> {noformat}
> Exception: [Error 193] %1 is not a valid Win32 application
> Traceback (most recent call last):
>   File "atlas_start.py", line 113, in <module>
>     returncode = main()
>   File "atlas_start.py", line 68, in main
>     mc.run_hbase(mc.hbaseBinDir(atlas_home), "start", hbase_conf_dir, 
> logdir)
>   File 
> "C:\OMS_main1\oms\atlas\distro\target\atlas\distro\target\apache-atlas-0.7-incubating-SNAPSHOT-bin\apache-atlas-0.7-incubating-SNAPSHOT\bin\atlas_config.py",

> line 365, in run_hbase
>     return runProcess(cmd, logdir, False, wait)
>   File 
> "C:\OMS_main1\oms\atlas\distro\target\atlas\distro\target\apache-atlas-0.7-incubating-SNAPSHOT-bin\apache-atlas-0.7-incubating-SNAPSHOT\bin\atlas_config.py",
line 194, in runProcess
>     p = subprocess.Popen(commandline, stdout=stdoutFile, stderr=stderrFile, shell=shell)
>   File "C:\Python27\lib\subprocess.py", line 710, in __init__
>     errread, errwrite)
>   File "C:\Python27\lib\subprocess.py", line 958, in _execute_child
>     startupinfo)
> WindowsError: [Error 193] %1 is not a valid Win32 application
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message