atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Suma Shivaprasad <sumasai.shivapra...@gmail.com>
Subject Re: Review Request 45929: ATLAS-628: Starting two Atlas instances at the same time causes exceptions in HA mode.
Date Wed, 20 Apr 2016 01:00:58 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45929/#review129660
-----------------------------------------------------------




webapp/src/main/java/org/apache/atlas/web/setup/SetupSteps.java (line 92)
<https://reviews.apache.org/r/45929/#comment193157>

    We need to add some documentation for this as part of Installation docs?.


- Suma Shivaprasad


On April 18, 2016, 6:31 p.m., Hemanth Yamijala wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45929/
> -----------------------------------------------------------
> 
> (Updated April 18, 2016, 6:31 p.m.)
> 
> 
> Review request for atlas.
> 
> 
> Bugs: ATLAS-628
>     https://issues.apache.org/jira/browse/ATLAS-628
> 
> 
> Repository: atlas
> 
> 
> Description
> -------
> 
> Implements capability in atlas to run a set of registered setup steps. Currently the
only step is setting up the backend graph repository. The intent is to extend this later for
setting up Kafka at least and maybe other things like Solr.
> 
> 
> Diffs
> -----
> 
>   distro/src/bin/atlas_start.py 7db74c0 
>   distro/src/conf/atlas-application.properties 4131240 
>   docs/src/site/twiki/Configuration.twiki 023f5a0 
>   repository/src/main/java/org/apache/atlas/repository/graph/GraphSchemaInitializer.java
PRE-CREATION 
>   server-api/src/main/java/org/apache/atlas/setup/SetupException.java PRE-CREATION 
>   server-api/src/main/java/org/apache/atlas/setup/SetupStep.java PRE-CREATION 
>   webapp/src/main/java/org/apache/atlas/Atlas.java 58c386d 
>   webapp/src/main/java/org/apache/atlas/web/service/ActiveInstanceState.java 6b39970

>   webapp/src/main/java/org/apache/atlas/web/service/AtlasZookeeperSecurityProperties.java
40a6030 
>   webapp/src/main/java/org/apache/atlas/web/service/CuratorFactory.java 773e04e 
>   webapp/src/main/java/org/apache/atlas/web/setup/AtlasSetup.java PRE-CREATION 
>   webapp/src/main/java/org/apache/atlas/web/setup/AtlasSetupModule.java PRE-CREATION

>   webapp/src/main/java/org/apache/atlas/web/setup/SetupSteps.java PRE-CREATION 
>   webapp/src/test/java/org/apache/atlas/web/service/AtlasZookeeperSecurityPropertiesTest.java
118587a 
>   webapp/src/test/java/org/apache/atlas/web/setup/SetupStepsTest.java PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/45929/diff/
> 
> 
> Testing
> -------
> 
> Existing ITs, UTs pass.
> 
> * Manually verified setting up with both embedded HBase setup and external HBase setup.
> * Also ran atlas HA instances at exactly same time and verified the noted exception does
not happen.
> 
> 
> Thanks,
> 
> Hemanth Yamijala
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message