atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-576) Build with Maven 3.0.5 fails
Date Tue, 22 Mar 2016 07:21:25 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-576?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15205940#comment-15205940
] 

Hemanth Yamijala commented on ATLAS-576:
----------------------------------------

[~rpatil], [~shwethags], I have Apache Maven 3.3.3 (always had). Did a mvn clean install today
and got the following error in the atlas-dashboard module:

{code}
[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm
(install node and npm) on project atlas-dashboard: Execution install node and npm of goal
com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm failed: A required class
was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm:
org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.22
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/Users/hyamijala/.m2/repository/com/github/eirslett/frontend-maven-plugin/0.0.22/frontend-maven-plugin-0.0.22.jar
[ERROR] urls[1] = file:/Users/hyamijala/.m2/repository/com/github/eirslett/frontend-plugin-core/0.0.22/frontend-plugin-core-0.0.22.jar
[ERROR] urls[2] = file:/Users/hyamijala/.m2/repository/org/codehaus/jackson/jackson-mapper-asl/1.9.13/jackson-mapper-asl-1.9.13.jar
[ERROR] urls[3] = file:/Users/hyamijala/.m2/repository/org/codehaus/jackson/jackson-core-asl/1.9.13/jackson-core-asl-1.9.13.jar
[ERROR] urls[4] = file:/Users/hyamijala/.m2/repository/org/apache/commons/commons-compress/1.5/commons-compress-1.5.jar
[ERROR] urls[5] = file:/Users/hyamijala/.m2/repository/org/tukaani/xz/1.2/xz-1.2.jar
[ERROR] urls[6] = file:/Users/hyamijala/.m2/repository/commons-io/commons-io/1.3.2/commons-io-1.3.2.jar
[ERROR] urls[7] = file:/Users/hyamijala/.m2/repository/org/apache/httpcomponents/httpclient/4.3.1/httpclient-4.3.1.jar
[ERROR] urls[8] = file:/Users/hyamijala/.m2/repository/org/apache/httpcomponents/httpcore/4.3/httpcore-4.3.jar
[ERROR] urls[9] = file:/Users/hyamijala/.m2/repository/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar
[ERROR] urls[10] = file:/Users/hyamijala/.m2/repository/commons-codec/commons-codec/1.6/commons-codec-1.6.jar
[ERROR] urls[11] = file:/Users/hyamijala/.m2/repository/javax/enterprise/cdi-api/1.0/cdi-api-1.0.jar
[ERROR] urls[12] = file:/Users/hyamijala/.m2/repository/javax/annotation/jsr250-api/1.0/jsr250-api-1.0.jar
[ERROR] urls[13] = file:/Users/hyamijala/.m2/repository/com/google/guava/guava/10.0.1/guava-10.0.1.jar
[ERROR] urls[14] = file:/Users/hyamijala/.m2/repository/com/google/code/findbugs/jsr305/1.3.9/jsr305-1.3.9.jar
[ERROR] urls[15] = file:/Users/hyamijala/.m2/repository/org/sonatype/sisu/sisu-guice/3.1.0/sisu-guice-3.1.0-no_aop.jar
[ERROR] urls[16] = file:/Users/hyamijala/.m2/repository/aopalliance/aopalliance/1.0/aopalliance-1.0.jar
[ERROR] urls[17] = file:/Users/hyamijala/.m2/repository/org/eclipse/sisu/org.eclipse.sisu.inject/0.0.0.M2a/org.eclipse.sisu.inject-0.0.0.M2a.jar
[ERROR] urls[18] = file:/Users/hyamijala/.m2/repository/asm/asm/3.3.1/asm-3.3.1.jar
[ERROR] urls[19] = file:/Users/hyamijala/.m2/repository/org/codehaus/plexus/plexus-component-annotations/1.5.5/plexus-component-annotations-1.5.5.jar
[ERROR] urls[20] = file:/Users/hyamijala/.m2/repository/org/apache/maven/plugin-tools/maven-plugin-annotations/3.2/maven-plugin-annotations-3.2.jar
[ERROR] urls[21] = file:/Users/hyamijala/.m2/repository/com/googlecode/slf4j-maven-plugin-log/slf4j-maven-plugin-log/1.0.0/slf4j-maven-plugin-log-1.0.0.jar
[ERROR] urls[22] = file:/Users/hyamijala/.m2/repository/org/sonatype/plexus/plexus-build-api/0.0.7/plexus-build-api-0.0.7.jar
[ERROR] urls[23] = file:/Users/hyamijala/.m2/repository/org/codehaus/plexus/plexus-utils/1.5.8/plexus-utils-1.5.8.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[project>org.apache.atlas:apache-atlas:0.7-incubating-SNAPSHOT,
parent: ClassRealm[maven.api, parent: null]]]
[ERROR] 
[ERROR] -----------------------------------------------------: org.slf4j.helpers.MarkerIgnoringBase
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException
{code}

This issue is referenced here: https://github.com/eirslett/frontend-maven-plugin/issues/179,
where the fix was to use 0.0.23 of frontend-maven-plugin. So, it appears our code base does
need 0.0.23 (and therefore possibly maven 3.3.x). Can you please check this?

> Build with Maven 3.0.5 fails
> ----------------------------
>
>                 Key: ATLAS-576
>                 URL: https://issues.apache.org/jira/browse/ATLAS-576
>             Project: Atlas
>          Issue Type: Bug
>    Affects Versions: trunk
>         Environment: Maven 3.0.5 on Mac OS X (10.10.5)
>            Reporter: Rajendra Patil
>            Assignee: Rajendra Patil
>            Priority: Trivial
>              Labels: Maven, dashboard, front-end, frontend
>             Fix For: 0.7-incubating
>
>         Attachments: ATLAS-576-1.patch, ATLAS-576-2.patch
>
>
> *Problem*:
> Atlast dashboard, the subproject fails due to maven frontend plugin version 0.0.23 that
needs maven 3.1.0
> ------
> INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2.598s
> [INFO] Finished at: Fri Mar 18 13:18:03 IST 2016
> [INFO] Final Memory: 14M/309M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.23:install-node-and-npm
(install node and npm) on project atlas-dashboard: The plugin com.github.eirslett:frontend-maven-plugin:0.0.23
requires Maven version 3.1.0 -> [Help 1]
> ------
> *Solution/Proposal*: frontend plugin  0.0.22 works absolutely fine and I don't think
we have any must have dependency on 0.0.23 or higher at this time. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message