atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anilsg (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-279) UI not displaying results for certain successful "select" search queries
Date Sun, 06 Dec 2015 19:05:10 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-279?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15044049#comment-15044049
] 

Anilsg commented on ATLAS-279:
------------------------------

[~yhemanth] [~rohitl]

This is updated with all the issues listed, 
Tested on:  http://52.27.169.250:3208/#!/search 

Do find the new patch file "ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v10.patch"

Note : Issue like No. 1 probably will be occurring, as the Json response is not consistent
across all the search quires.
           For Issue No. 2,3 we have tested with the quick start data available with us, As
we know we don't have hive module set up ( Taking help from Hemanth to set up Hive module).
 So we have not able to test with the hive search test quires. 
       

> UI not displaying results for certain successful "select" search queries
> ------------------------------------------------------------------------
>
>                 Key: ATLAS-279
>                 URL: https://issues.apache.org/jira/browse/ATLAS-279
>             Project: Atlas
>          Issue Type: Bug
>    Affects Versions: 0.5-incubating
>            Reporter: Ayub Khan
>            Assignee: Anilsg
>              Labels: patch-available
>             Fix For: 0.6-incubating
>
>         Attachments: ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239-ATLAS-345_v8.patch,
ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v1.patch, ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v10.patch,
ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v2.patch, ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v3.patch,
ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v4.patch, ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v5.patch,
ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v6.patch, ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v7.patch,
ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264-ATLAS-239_v9.patch, ATLAS-279-ATLAS-268-ATLAS-244-ATLAS-264_v0.patch,
can_select_empty_line_in_parents.png, hive_table_select_bug.png, hive_table_select_bug.txt,
tag_addition_missing_attr_name_bug.png, tag_addition_missing_attr_name_bug.txt, tag_association_missing_child_attrs.png
>
>
> UI not displaying results for certain successful "select" search queries
> For example: Below search query returns 6 results but none are shown on UI. Link for
UI snapshot: https://monosnap.com/file/1yNz13MGbe3t6vPvDNqrKqurW6K3Es
> {noformat}
> curl 'http://localhost:21000/api/atlas/discovery/search?query=from+Table+select+Table.name'
-H 'Accept: application/json, text/plain, */*' -H 'Connection: keep-alive' -H 'Accept-Encoding:
gzip, deflate, sdch' -H 'Referer: http://localhost:21000/' -H 'Accept-Language: en-US,en;q=0.8'
-H 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML,
like Gecko) Chrome/46.0.2490.80 Safari/537.36' --compressed | python -m json.tool
> {
>     "count": 6,
>     "query": "from Table select Table.name",
>     "queryType": "dsl",
>     "requestId": "qtp1946331169-37253 - 4d068946-1df3-4c60-8671-584e2901c9ee",
>     "results": {
>         "dataType": {
>             "attributeDefinitions": [
>                 {
>                     "dataTypeName": "string",
>                     "isComposite": false,
>                     "isIndexable": true,
>                     "isUnique": false,
>                     "multiplicity": {
>                         "isUnique": false,
>                         "lower": 0,
>                         "upper": 1
>                     },
>                     "name": "_col_0",
>                     "reverseAttributeName": null
>                 }
>             ],
>             "typeName": "__tempQueryResultStruct625"
>         },
>         "query": "Table as _src1 select _src1.name as _col_0",
>         "rows": [
>             {
>                 "$typeName$": "__tempQueryResultStruct625",
>                 "_col_0": "product_dim"
>             },
>             {
>                 "$typeName$": "__tempQueryResultStruct625",
>                 "_col_0": "sales_fact"
>             },
>             {
>                 "$typeName$": "__tempQueryResultStruct625",
>                 "_col_0": "customer_dim"
>             },
>             {
>                 "$typeName$": "__tempQueryResultStruct625",
>                 "_col_0": "time_dim"
>             },
>             {
>                 "$typeName$": "__tempQueryResultStruct625",
>                 "_col_0": "sales_fact_daily_mv"
>             },
>             {
>                 "$typeName$": "__tempQueryResultStruct625",
>                 "_col_0": "sales_fact_monthly_mv"
>             }
>         ]
>     }
> }
> {noformat}
> Other such successful queries which are not displayed on UI are:
> http://localhost:21000/api/atlas/discovery/search?query=Column+select+Column.name
> http://localhost:21000/api/atlas/discovery/search?query=from+DB+select+DB.name



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message