atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shwetha G S (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ATLAS-242) lineage hive table schema REST API does not accept any tableName value
Date Thu, 29 Oct 2015 08:18:27 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-242?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14980030#comment-14980030
] 

Shwetha G S edited comment on ATLAS-242 at 10/29/15 8:17 AM:
-------------------------------------------------------------

The table name should be of fully qualified name of format - dbname.tablename@clustername


was (Author: shwethags):
The table name should be of format - dbname.tablename@clustername

> lineage hive table schema REST API does not accept any tableName value
> ----------------------------------------------------------------------
>
>                 Key: ATLAS-242
>                 URL: https://issues.apache.org/jira/browse/ATLAS-242
>             Project: Atlas
>          Issue Type: Bug
>            Reporter: David Kaspar
>
> This issue is filed for "RangerAtlasDemo_v4.ova" VM-image release.
> When I call:
> http://127.0.0.1:21000/api/atlas/lineage/hive/table/{tableName}/schema
> REST API method, then it always returns 404 Not Found and returns an error which claims
that given {tableName} does not exist.
> Since REST API documentation (application.wadl) does not state details, I have tried
to use existing Hive table names, existing GUIDs of Hive tables but none of them works.
> Similarly for /api/atlas/lineage/hive/table/{tableName}/outputs/graph and /api/atlas/lineage/hive/table/{tableName}/inputs/graph.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message