atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "liutongfeng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ATLAS-199) webapp build fails (grunt + tests)
Date Sat, 10 Oct 2015 07:43:05 GMT

    [ https://issues.apache.org/jira/browse/ATLAS-199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14951678#comment-14951678
] 

liutongfeng commented on ATLAS-199:
-----------------------------------

Just delete the activation directory, and change to the same as the profile 'grunt-task'.


diff --git a/webapp/pom.xml b/webapp/pom.xml
index 8992d42..a7cee9d 100755
--- a/webapp/pom.xml
+++ b/webapp/pom.xml
@@ -124,9 +124,9 @@
         <profile>
             <id>bower-install</id>
             <activation>
-                <file>
-                    <missing>target/dist/lib</missing>
-                </file>
+                <property>
+                    <name>!disableGrunt</name>
+                </property>
             </activation>
             <build>
                 <plugins>

> webapp build fails (grunt + tests)
> ----------------------------------
>
>                 Key: ATLAS-199
>                 URL: https://issues.apache.org/jira/browse/ATLAS-199
>             Project: Atlas
>          Issue Type: Bug
>    Affects Versions: 0.6-incubating
>            Reporter: Erik Bergenholtz
>            Assignee: Darshan Kumar
>            Priority: Critical
>              Labels: patch-available
>             Fix For: 0.6-incubating
>
>         Attachments: ATLAS-199-v0.patch
>
>
> When building Atlas webapp, I see the following issues:
> mvn clean install:
> {code}
> [INFO] Running 'grunt bower --no-color' in /Users/ebergenholtz/git3/incubator-atlas/dashboard
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 34.282 s
> [INFO] Finished at: 2015-09-30T13:55:30-05:00
> [INFO] Final Memory: 35M/420M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.23:grunt
(install bower) on project atlas-webapp: Failed to run task: 'grunt bower --no-color' failed.
java.io.IOException: Cannot run program "/Users/ebergenholtz/git3/incubator-atlas/dashboard/node/node"
(in directory "/Users/ebergenholtz/git3/incubator-atlas/dashboard"): error=2, No such file
or directory -> [Help 1]
> {code}
> Also, if I bypass the grunt task some of the tests fail.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message