atlas-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Herman Yu <herman...@teeupdata.com>
Subject Re: Search syntax
Date Wed, 23 Sep 2015 15:00:42 GMT
Hi Suma,
Thanks for the help. I tried as you suggested, “hive_table is collection”, however "0
results matching your search query hive_table is collection were found”.
“collection” is a trait I defined, if I just search with “collection” in the UI, I
have two hive_table entities returned. 
I also tried with those types and traits defined with the quick_start.py, (e.g. "Table is
Fact" didn’t return anything.
Is this a bug with v0.5? or I used wrong search syntax? Is there a document with all valid
search syntax?

thanks
Herman.


On Sep 21, 2015, at 10:54 PM, Herman Yu <herman.yu@teeupdata.com> wrote:

Hi Herman,

You can fire a DSL query in the UI as "hive_table  is "trait_name"

Thanks
Suma
> Hi,
> 
> With version v0.5, is search based on combination of a Trait and a type supported?  I
have both hive_tables and hive_columns associated with a Trait. I can search base on the Trait,
or search based on the type(hive_table or hive_colume). How to combine them together, for
example, search the trait but only want to return hive_table?
> 
> I tried <traitName> and <hive_table>, <traitName> and typeName=<hive_table>
in both UI and REST API, it doesn’t work.
> 
> This is my first time posting here, sorry if this is not the right place asking questions
like this. If so, what would be the correct channel?
> 
> Thanks
> Herman.
> 
> 


Mime
View raw message