asterixdb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Maxon <ima...@uci.edu>
Subject Re: FW: CSE 514: AsterixDB Error
Date Wed, 22 Feb 2017 02:12:05 GMT
The ClassNotFound for AsterixHelper is due to a bug in a script, but as
Yingyi said it should not affect the operation of the cluster directly. If
you see 3 terminal windows open after running the script it should have
done most of its job.

On Tue, Feb 21, 2017 at 4:29 PM, Yingyi Bu <buyingyi@gmail.com> wrote:

> Erin,
>
> -- BTW, the class-not-found issues shown in the Power Shell shouldn't
> prevent you running queries.  For now, you can ignore them.
> -- For "MetadataNode failed to bind",  I guess it could be fixed by
> appending the line "storage.metadata.memorycomponent.numpages=16" to
> samples/local/conf/cc.conf  and restart everything.  By doing this, I
> fixed the error at my Windows instance.
>
> Best,
> Yingyi
>
>
> On Tue, Feb 21, 2017 at 4:25 PM, Yingyi Bu <buyingyi@gmail.com> wrote:
>
>> Hi Orbite,
>>
>>    For the issue of "The MetadataNode failed to bind":
>>     What's the RAM size of your Windows machine?  I suspect it is not
>> very large.
>>
>>     I run into the same issue when I had 1GB RAM.  I fixed that by adding
>> this line to the end of samples/local/conf/cc.conf:
>>    storage.metadata.memorycomponent.numpages=16
>>
>>
>> Best,
>> Yingyi
>>
>> On Tue, Feb 21, 2017 at 4:14 PM, <orbite@uw.edu> wrote:
>>
>>> Hello,
>>>
>>>
>>>
>>> I’m a student in Dan’s Database Management class, and I followed your
>>> instructions for the Windows platform, but I’m having problems. There’s a
>>> screenshot below with the error code, and I also attached a screenshot of
>>> the error I get with the PowerShell.  Could you help me with this error?
>>>
>>>
>>>
>>>
>>>
>>> Thanks,
>>>
>>>
>>>
>>> Erin Orbits, J.D.
>>> University of Wash., Dept. of Data Science
>>>
>>>
>>>
>>> *From: *orbite@uw.edu
>>> *Sent: *Monday, February 20, 2017 1:27 AM
>>> *To: *Weston Wei <wwhqwe@gmail.com>
>>> *Subject: *CSE 514: AsterixDB Error
>>>
>>>
>>>
>>> Hello,
>>>
>>>
>>>
>>> I followed the instructions from Yingyi, and managed to get a Firefox
>>> browser window for AsterixDB, but then when I entered the initial commands,
>>> I got the error:
>>>
>>> The MetadataNode failed to bind before the configured timeout (60 seconds); the
MetadataNode was configured to run on NC: red [HyracksDataException]
>>>
>>> (see the photo)
>>>
>>> [image: cid:image001.jpg@01D28B18.17FBA750]
>>>
>>> I have absolutely no idea what that error means… Any thoughts on what
>>> I’m doing wrong?
>>>
>>>
>>>
>>> Thanks,
>>>
>>> ~ Erin
>>>
>>>
>>>
>>
>>
>

Mime
View raw message