asterixdb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Westmann" <ti...@apache.org>
Subject Re: Using NCService to build AsterixDB on cluster
Date Sat, 24 Sep 2016 01:51:45 GMT
Hi Mingda,

have you started the NCService processes manually on the cluster nodes?
Maybe you only have an NCService running on one node?

Cheers,
Till

On 23 Sep 2016, at 18:18, mingda li wrote:

> I have tried to modify the cc.conf to another form as following. But 
> when I
> run all NCs and the CC. It actually started only the nc/red and cc.
> Has anyone met the problem before while using NCService to configure
> AsterixDB?
>
> [nc4/red4]
>
> txnlogdir=/tmp/asterix/red4/txnlog
>
> coredumpdir=/tmp/asterix/red4/coredump
>
> iodevices=/tmp/asterix/red4
>
> address=131.179.64.23
>
> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>
> storagedir=storage
>
> command=asterixnc
>
> [nc3/red3]
>
> txnlogdir=/tmp/asterix/red3/txnlog
>
> coredumpdir=/tmp/asterix/red3/coredump
>
> iodevices=/tmp/asterix/red3
>
> address=131.179.64.22
>
> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>
> storagedir=storage
>
> command=asterixnc
>
> [nc2/red2]
>
> txnlogdir=/tmp/asterix/red2/txnlog
>
> coredumpdir=/tmp/asterix/red2/coredump
>
> iodevices=/tmp/asterix/red2
>
> address=131.179.64.21
>
> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>
> storagedir=storage
>
> command=asterixnc
>
> [nc/red]
>
> txnlogdir=/tmp/asterix/red/txnlog
>
> coredumpdir=/tmp/asterix/red/coredump
>
> iodevices=/tmp/asterix/red
>
> address=131.179.64.20
>
> [nc]
>
> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>
> storagedir=storage
>
> command=asterixnc
>
> [cc]
>
> cluster.address = 131.179.64.20
>
> http.port = 12345
>
> On Fri, Sep 23, 2016 at 10:26 AM, mingda li <limingda1993@gmail.com> 
> wrote:
>
>> Dear Blow,
>>
>> Thanks, I have tried to modify the cc.conf file according to your 
>> advice
>> to the following. But when I open the http://masterNode:19002/
>> admin/cluster, I found that it returns {"State":"UNUSABLE","
>> Metadata_Node":"red4","partition_3":"red"}.
>> And the asterixDB on  http://masterNode:19001 cannot work. Could you 
>> tell
>> me if I have make another mistake?
>>
>> Thanks,
>> Mingda
>>
>> *cc.conf:*
>>
>> *[nc/red4]*
>>
>> *txnlogdir=/tmp/asterix/red4/txnlog*
>>
>> *coredumpdir=/tmp/asterix/red4/coredump*
>>
>> *iodevices=/tmp/asterix/red4*
>>
>> *address=131.179.64.23*
>>
>> *[nc/red3]*
>>
>> *txnlogdir=/tmp/asterix/red3/txnlog*
>>
>> *coredumpdir=/tmp/asterix/red3/coredump*
>>
>> *iodevices=/tmp/asterix/red3*
>>
>> *address=131.179.64.22*
>>
>> *[nc/red2]*
>>
>> *txnlogdir=/tmp/asterix/red2/txnlog*
>>
>> *coredumpdir=/tmp/asterix/red2/coredump*
>>
>> *iodevices=/tmp/asterix/red2*
>>
>> *address=131.179.64.21*
>>
>> *[nc/red]*
>>
>> *txnlogdir=/tmp/asterix/red/txnlog*
>>
>> *coredumpdir=/tmp/asterix/red/coredump*
>>
>> *iodevices=/tmp/asterix/red*
>>
>> *address=131.179.64.20*
>>
>>
>> *[nc]*
>>
>> *app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint*
>>
>> *storagedir=storage*
>>
>> *command=asterixnc*
>>
>>
>> *[cc]*
>>
>> *cluster.address = 131.179.64.20*
>>
>> *http.port = 12345*
>>
>>
>> On Thu, Sep 22, 2016 at 8:17 PM, Michael Blow 
>> <mblow.apache@gmail.com>
>> wrote:
>>
>>> There is just nc and nc/<node> sections, you should not have nc1, 
>>> nc2,
>>> etc. also, each no must be unique name, you can not name them all 
>>> 'red'
>>>
>>> Hope it helps,
>>>
>>> Thanks,
>>>
>>> -MDB
>>>
>>> On Thu, Sep 22, 2016 at 8:33 PM mingda li <limingda1993@gmail.com> 
>>> wrote:
>>>
>>>> Dear all,
>>>>
>>>> These days, I am building the AsterixDB on cluster following the
>>>> instruction here:
>>>> https://ci.apache.org/projects/asterixdb/ncservice.html
>>>>
>>>> There are one master node with one nc and three cluster nodes with 
>>>> one
>>>> nc each machine. The cc.conf is as following. And after I use
>>>> $BASEDIR/bin/asterixncservice >red-service.log 2>&1 & to start

>>>> three
>>>> cluster nodes' AsterixDB and the master node's AsterixDB,   I run 
>>>> $BASEDIR/bin/asterixcc
>>>> -config-file cc.conf > cc.log 2>&1 & to start the CC.  There
is no
>>>> error message and I can open the http://master:19001 and run aql. 
>>>> But
>>>> when I open the http://master:19002/admin/cluster, there is only 
>>>> one nc
>>>> here 
>>>> ({"State":"ACTIVE","Metadata_Node":"red","partition_0":"red"}). I
>>>> couldn't find the ncs on other machines. Does anyone know why?
>>>>
>>>> Thanks,
>>>> Mingda
>>>>
>>>> cc.conf file is as following:
>>>> [nc4/red] txnlogdir=/tmp/asterix/red/txnlog
>>>> coredumpdir=/tmp/asterix/red/coredump iodevices=/tmp/asterix/red
>>>> [nc4] 
>>>> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>>>> storagedir=storage address=131.179.64.23 command=asterixnc
>>>> [nc3/red] txnlogdir=/tmp/asterix/red/txnlog
>>>> coredumpdir=/tmp/asterix/red/coredump iodevices=/tmp/asterix/red
>>>> [nc3] 
>>>> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>>>> storagedir=storage address=131.179.64.22 command=asterixnc
>>>> [nc2/red] txnlogdir=/tmp/asterix/red/txnlog
>>>> coredumpdir=/tmp/asterix/red/coredump iodevices=/tmp/asterix/red
>>>> [nc2] 
>>>> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>>>> storagedir=storage address=131.179.64.21 command=asterixnc
>>>> [nc/red] txnlogdir=/tmp/asterix/red/txnlog
>>>> coredumpdir=/tmp/asterix/red/coredump iodevices=/tmp/asterix/red
>>>> [nc] 
>>>> app.class=org.apache.asterix.hyracks.bootstrap.NCApplicationEntryPoint
>>>> storagedir=storage address=131.179.64.20 command=asterixnc
>>>> [cc] cluster.address = 131.179.64.20 http.port = 12345
>>>>
>>>>
>>>>
>>



Mime
View raw message