asterixdb-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wail Alkowaileet <wael....@gmail.com>
Subject Re: Field accessor not defined for values of type null
Date Sun, 20 Sep 2015 23:00:41 GMT
Hi Namrata,
This is the one I tested:
https://asterixdb.ics.uci.edu/download/snapshots/asterix-installer-0.8.7-SNAPSHOT-binary-assembly.zip
,

I shrunk it by deleting some of its values to see if the size of
analysed_sst was the reason why I get the Hyracks error.

On Mon, Sep 21, 2015 at 1:41 AM, Malarout, Namrata (398M-Affiliate) <
Namrata.Malarout@jpl.nasa.gov> wrote:

> Which version are you currently using? Thanks for your time.
> -Namrata
> From: Wail Alkowaileet <wael.y.k@gmail.com>
> Reply-To: "users@asterixdb.incubator.apache.org" <
> users@asterixdb.incubator.apache.org>
> Date: Sunday, September 20, 2015 at 3:36 PM
>
> To: "users@asterixdb.incubator.apache.org" <
> users@asterixdb.incubator.apache.org>
> Subject: Re: Field accessor not defined for values of type null
>
> I didn't test the last snapshot of AsterixDB.
> I remember reading somewhere that the new version can handle a record
> larger than a page.
>
> Sorry for not being helpful.
> On 21 Sep 2015 1:22 am, "Wail Alkowaileet" <wael.y.k@gmail.com> wrote:
>
>> I didn't encounter the same error.
>>
>> I did the following:
>> use dataverse exp;
>> drop dataset jpl if exists
>> drop type jplType if exists
>> create type jplType as open
>> {
>>     fid:uuid
>> }
>> create dataset jpl(jplType)
>> primary key fid;
>>
>> load dataset jpl using localfs
>>     (("path"="127.0.0.1:///Users/wail/Dropbox
>> (MIT)/AsterixConnector/d-plus-m.adm"),("format"="adm"));
>>
>> I only defined fid in my open jplType. However, I got different error:
>> "Unable to allocate frame larger than:255 bytes [HyracksDataException]"
>>
>> analysed_sst was too large for Hyracks to handle. After shrinking it, I
>> was able to load it.
>>
>>
>>
>> On Mon, Sep 21, 2015 at 12:23 AM, Malarout, Namrata (398M-Affiliate) <
>> Namrata.Malarout@jpl.nasa.gov> wrote:
>>
>>> Hi,
>>> I’ve attached a text file containing the schema. It isn’t very detailed
>>> as of now. I want to see how long it takes for the data to get ingested.
>>> Here a link to the data:
>>>
>>> https://drive.google.com/file/d/0B6wmo4_-H0P2UUhJcFpVdWdZT1k/view?usp=sharing
>>> It is one record from the sample data. I tried to attach it but it
>>> failed while sending a couple of times.
>>> Thanks,
>>> Namrata
>>>
>>> From: Wail Alkowaileet <wael.y.k@gmail.com>
>>> Reply-To: "users@asterixdb.incubator.apache.org" <
>>> users@asterixdb.incubator.apache.org>
>>> Date: Sunday, September 20, 2015 at 2:03 PM
>>>
>>> To: "users@asterixdb.incubator.apache.org" <
>>> users@asterixdb.incubator.apache.org>
>>> Subject: Re: Field accessor not defined for values of type null
>>>
>>> Hi,
>>> Can you please provide me the full schema and an example of the data?
>>> I want to replicate the error
>>>
>>> Thanks!
>>>
>>> On Sun, Sep 20, 2015 at 11:44 PM, Malarout, Namrata (398M-Affiliate) <
>>> Namrata.Malarout@jpl.nasa.gov> wrote:
>>>
>>>> Hi,
>>>> I was just trying to load the .adm file. This was my query:
>>>>
>>>> use dataverse TestL4;
>>>>
>>>> load dataset GlobL4 using localfs
>>>>
>>>>
>>>> (("path"="LMC-015412:///Users/malarout/Desktop/d-plus-m.adm"),("format"="adm"));
>>>>
>>>> Thanks,
>>>>
>>>> Namrata
>>>>
>>>> From: Wail Alkowaileet <wael.y.k@gmail.com>
>>>> Reply-To: "users@asterixdb.incubator.apache.org" <
>>>> users@asterixdb.incubator.apache.org>
>>>> Date: Sunday, September 20, 2015 at 1:35 PM
>>>> To: "users@asterixdb.incubator.apache.org" <
>>>> users@asterixdb.incubator.apache.org>
>>>> Subject: Re: Field accessor not defined for values of type null
>>>>
>>>> Hi Namrata,
>>>> What was your query?
>>>>
>>>> Thanks!
>>>>
>>>> On Sun, Sep 20, 2015 at 11:12 PM, Malarout, Namrata (398M-Affiliate) <
>>>> Namrata.Malarout@jpl.nasa.gov> wrote:
>>>>
>>>>> Hi all,
>>>>> I am trying to load data into AsterixDB. But I keep getting this error:
>>>>>
>>>>> Field accessor is not defined for values of type null [AlgebricksException]
>>>>>
>>>>> This is the data, (1,291) is the position where the axis starts:
>>>>> "comment":"","axis":"T"
>>>>> I changed the blank field to null. So now the data
>>>>> is: "comment":null,"axis":”T"
>>>>> But I’m still getting the same error. In the schema comment has been
>>>>> declared as comment:string? . I’ve made it optional. Is there something
>>>>> else that I need to take care of? What does is a field accessor?
>>>>> Thank in advance for the help.
>>>>> Regards,
>>>>> Namrata Malarout
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> *Regards,*
>>>> Wail Alkowaileet
>>>>
>>>
>>>
>>>
>>> --
>>>
>>> *Regards,*
>>> Wail Alkowaileet
>>>
>>
>>
>>
>> --
>>
>> *Regards,*
>> Wail Alkowaileet
>>
>


-- 

*Regards,*
Wail Alkowaileet

Mime
View raw message