asterixdb-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "abdullah alamoudi (Code Review)" <>
Subject Change in asterixdb[master]: Add Test NodeController, Test Data Generator, and Marker Logs
Date Thu, 21 Jul 2016 12:08:27 GMT
abdullah alamoudi has posted comments on this change.

Change subject: Add Test NodeController, Test Data Generator, and Marker Logs

Patch Set 10:

File asterixdb/asterix-algebra/src/main/java/org/apache/asterix/algebra/operators/physical/

Line 89:             logRecord = new LogRecord(callback);
> This is a nice improvement.
Thank you :)
File asterixdb/asterix-app/src/test/java/org/apache/asterix/app/bootstrap/

Line 275:                 AsterixRuntimeComponentsProvider.RUNTIME_PROVIDER, LSMBTreeIOOperationCallbackFactory.INSTANCE,
> What is the meaning of "0.01"? Could we have a symbolic name?

Line 288:                 AsterixRuntimeComponentsProvider.RUNTIME_PROVIDER, LSMBTreeIOOperationCallbackFactory.INSTANCE,
> s.a.
File asterixdb/asterix-common/src/main/java/org/apache/asterix/common/context/

Line 733:                             : storageProperties.getMemoryComponentNumPages();
> not a fan, i think the original version is much easier to read

Line 759:             int numPages =
> not a fan, i think the original version is much easier to read
File asterixdb/asterix-common/src/main/java/org/apache/asterix/common/dataflow/

Line 49:     // we already have an index field!! should we add another pointer to the same
> Could you elaborate more on the comment?
File asterixdb/asterix-common/src/main/java/org/apache/asterix/common/transactions/

Line 28:     public static final String KEY_MARKER_CALLBACK = "MARKER_CALLBACK";
> Should we remove the redundant modifiers (public static final) given that t

Line 36:     public void before(ByteBuffer buffer);
> remove public

Line 43:     public void after(long lsn);
> remove public
File asterixdb/asterix-common/src/main/java/org/apache/asterix/common/transactions/

Line 134:         switch (logType) {
> Much better with the switch.

Line 258:         switch (logType) {
> Can we restore the default case?  Even if a no-op, this is good documentati
File asterixdb/asterix-common/src/main/java/org/apache/asterix/common/utils/

Line 92:                 file.getParentFile().mkdirs();
> Isn't the issue still present, (reported in patch 7)
That is right. I just added a comment because I don't think it should be taken care of in
this static method. It is the responsibility of the caller.
File asterixdb/asterix-external-data/src/main/java/org/apache/asterix/external/dataflow/

Line 220:                             // TODO (amoudi): find a better reactive way to do this
> It might be helpful to add a JIRA issue for yourself for this that describe
Will do once this makes it to master. As of now, this issue doesn't exist (yet!) :-)
File hyracks-fullstack/hyracks/hyracks-api/src/main/java/org/apache/hyracks/api/context/

Line 48:     public void set(String key, Object value);
> I'm confused about this interface change. The idea of the shared object was

Notice that we sometimes need to store multiple objects in the taskCtx. Now, take a look in
the next patch as to which classes had to change because of this.
File hyracks-fullstack/hyracks/hyracks-dataflow-common/src/main/java/org/apache/hyracks/dataflow/common/io/

Line 119:             int messageSize = message.getBuffer().limit() - message.getBuffer().position();
> Can we add a local final variable for message.getBuffer()?  Seems nice sinc
File hyracks-fullstack/hyracks/hyracks-storage-am-common/src/main/java/org/apache/hyracks/storage/am/common/freepage/

Line 476:             return (metadataPageNum * bufferCache.getPageSize()) + LIFOMetaDataFrame.LSN_OFFSET;
> +1- I would cast bufferCache.getPageSize() to long

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: I3b9aa8de758b7d26ca34868b16e5ce693e0c0243
Gerrit-PatchSet: 10
Gerrit-Project: asterixdb
Gerrit-Branch: master
Gerrit-Owner: abdullah alamoudi <>
Gerrit-Reviewer: Jenkins <>
Gerrit-Reviewer: Michael Blow <>
Gerrit-Reviewer: Till Westmann <>
Gerrit-Reviewer: abdullah alamoudi <>
Gerrit-HasComments: Yes

View raw message