asterixdb-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murtadha Hubail (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ASTERIXDB-1273) sporadic test hang because of NPE in AsterixFileMapManager
Date Mon, 25 Jan 2016 03:11:39 GMT

    [ https://issues.apache.org/jira/browse/ASTERIXDB-1273?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15114690#comment-15114690
] 

Murtadha Hubail commented on ASTERIXDB-1273:
--------------------------------------------

I spent some time trying to create scenarios which could produce the same error. One way this
error could happen if the index was deactivated while a flush is happening and when the flush
completed and tried to schedule a merge, the merge couldn't find some of the files of the
components to be merged. However, I made sure that there is a wait for any IO operation before
the index is deactivated.

I have implemented a fix that will eliminate this specific error of "No mapping found" during
a merge operation, but if whatever caused this to happen happens again, a different error
should show up. Hopefully the new error will give us more clues to why this happened.

The strange thing is that none of our test cases, apart from the merge test cases, should
trigger a merge on our build configurations.

> sporadic test hang because of NPE in AsterixFileMapManager
> ----------------------------------------------------------
>
>                 Key: ASTERIXDB-1273
>                 URL: https://issues.apache.org/jira/browse/ASTERIXDB-1273
>             Project: Apache AsterixDB
>          Issue Type: Bug
>          Components: Storage
>            Reporter: Yingyi Bu
>            Assignee: Murtadha Hubail
>              Labels: sporadic-error
>
> I run into this issue once sporadically on Jenkins.
> Expected results file: src/test/resources/runtimets/results/dml/scan-delete-inverted-index-word-secondary-index-nullable/scan-delete-inverted-index-word-secondary-index-nullable.1.adm
> org.apache.hyracks.api.exceptions.HyracksDataException: No mapping found for id: 1007
> 	at org.apache.asterix.common.context.AsterixFileMapManager.lookupFileName(AsterixFileMapManager.java:40)
> 	at org.apache.hyracks.storage.am.lsm.btree.impls.LSMBTree.scheduleMerge(LSMBTree.java:492)
> 	at org.apache.hyracks.storage.am.lsm.common.impls.LSMHarness.scheduleMerge(LSMHarness.java:419)
> 	at org.apache.hyracks.storage.am.lsm.common.impls.LSMTreeIndexAccessor.scheduleMerge(LSMTreeIndexAccessor.java:132)
> 	at org.apache.hyracks.storage.am.lsm.common.impls.PrefixMergePolicy.diskComponentAdded(PrefixMergePolicy.java:85)
> 	at org.apache.hyracks.storage.am.lsm.common.impls.LSMHarness.exitComponents(LSMHarness.java:237)
> 	at org.apache.hyracks.storage.am.lsm.common.impls.LSMHarness.flush(LSMHarness.java:404)
> 	at org.apache.hyracks.storage.am.lsm.common.impls.LSMTreeIndexAccessor.flush(LSMTreeIndexAccessor.java:105)
> 	at org.apache.hyracks.storage.am.lsm.btree.impls.LSMBTreeFlushOperation.call(LSMBTreeFlushOperation.java:69)
> 	at org.apache.hyracks.storage.am.lsm.btree.impls.LSMBTreeFlushOperation.call(LSMBTreeFlushOperation.java:34)
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
> 	at java.lang.Thread.run(Thread.java:745)
> Expected results file: src/test/resources/runtimets/results/dml/load-with-index-open/load-with-index-open.1.adm
> Build timed out (after 120 minutes). Marking the build as aborted.
> channel stopped



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message