asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wail Alkowaileet <wael....@gmail.com>
Subject Re: Change in merge policy syntax
Date Tue, 28 Nov 2017 03:31:52 GMT
+1

On Nov 27, 2017 19:24, "abdullah alamoudi" <bamousaa@gmail.com> wrote:

> Dear devs,
> We would like to get your input on changing the syntax of the merge policy
> definition.
>
> Current syntax:
> <USING> <COMPACTION> <POLICY> prefix_merge (("number"="123"),("size"="
> 456"));
>
> Proposed syntax
> <WITH> {"compaction policy": {"name": "prefix_merge", "parameters":
> {"number": 123,"size": 456}}};
>
> Advantages:
> 1. Compaction and policy are not key words anymore.
> 2. Use a JSON for key value pairs instead of a strange syntax.
>
> Thoughts?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message