asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siddhesh Rane <SiddheshR...@disroot.org>
Subject RE: meet problem in compiling asterixdb
Date Wed, 26 Apr 2017 07:40:07 GMT
I have successfully compiled AsterixDB from source. I too encountered a lot of errors like
these. In my experience the problem was not with the code base but with the network. 
AsterixDB has a lot of dependencies. When compiling for the first time chances are you'll
not have all of them in your local maven repo. The initial build is filled with dependency
downloads, but not all of them get downloaded. 

To confirm this behaviour try restarting the compile process again. If everytime you encounter
maven downloading some or the other dependencies then the problem is with your university/organization
network. You'll need to run the build multiple times just for it to download all dependencies.


Deleting caches won't help. 

Regards 
Siddhesh Rane 

---- zater wrote ----

>To developer: 
>
>I want to use maven to compile this  project. I meet the problem : 
>
>
>[ERROR] Failed to parse plugin descriptor for org.apache.hyracks:license-automation-plugin:0.3.1-SNAPSHOT
(C:\Users\zater\git\asterixdb\hyracks-fullstack\hyracks\hyracks-maven-plugins\license-automation-plugin\target\classes):
No plugin descriptor found at META-INF/maven/plugin.xml -> [Help 1] 
>
>[ERROR] 
>
>[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. 
>
>[ERROR] Re-run Maven using the -X switch to enable full debug logging. 
>
>[ERROR] 
>
>[ERROR] For more information about the errors and possible solutions, please read the
following articles: 
>
>[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginDescriptorParsingException

>
>
>I read this link and search google. Found remove the whole repository may works. I do
it and  do not work. I even try to remove the "C:\Users\zater\git\asterixdb\hyracks-fullstack\hyracks\hyracks-maven-plugins\license-automation-plugin\target\classes",
also do not work. Can you give me some guidance on it? Thanks! 
>
>Zater 
>
>2017/4/24 
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message