asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Taewoo Kim <wangs...@gmail.com>
Subject Re: Eclipse - Plugin execution not covered by lifecycle configuration error
Date Thu, 20 Oct 2016 00:21:09 GMT
It looks like that there is no m2e connector for analyze-only plugin. I
think we need to add this plugin to the plugin management section of
pom.xml file so that this could be ignored on Eclipse only.

Best,
Taewoo

On Wed, Oct 19, 2016 at 5:06 PM, Taewoo Kim <wangsaeu@gmail.com> wrote:

> Thanks Till. Let me check that.
>
> Best,
> Taewoo
>
> On Wed, Oct 19, 2016 at 4:45 PM, Till Westmann <tillw@apache.org> wrote:
>
>> Hi,
>>
>> I haven’t seen this (as I don’t use eclipse), but I can tell you where
>> it’s coming from. We’ve added the maven-dependency-plugin to validate
>> that the dependencies that are declared in the POM actually match what
>> it being used by the module. The build will fail if dependencies are
>> missing or if we declare dependencies that are not being used in the
>> module. The goal is to have precise dependency information to be able
>> to produce correct LICENSE/NOTICE files for our binary artifacts.
>>
>> I would guess that there's a way to integrate that plugin with the
>> eclipse build using m2e, but it's just a guess ...
>>
>> Maybe somebody else took a look at this and knows more?
>>
>> Cheers,
>> Till
>>
>> [1] http://www.eclipse.org/m2e/
>>
>> On 19 Oct 2016, at 16:33, Taewoo Kim wrote:
>>
>> > Hi all,
>> >
>> > Since a few days ago, I have seen the following error. Has anyone seen
>> this
>> > error, too?
>> >
>> > Plugin execution not covered by lifecycle configuration:
>> > org.apache.maven.plugins:maven-dependency-plugin:2.10:*analyze-only*
>> > (execution: default, phase: process-test-classes)
>> >
>> > Best,
>> > Taewoo
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message