asterixdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Westmann" <ti...@apache.org>
Subject Re: RecoveryIT failing ...
Date Sun, 14 Aug 2016 18:26:40 GMT
On 14 Aug 2016, at 1:17, abdullah alamoudi wrote:

> Clearly, this problem is caused by the first failure only. Subsequent
> failures are caused by the state left behind by the first test but you
> already know that.

Well, I kind of do, but I’ve never had to deal with failures of the 
ITs
that happened on Jenkins but work on my machine. So far the failures I
produced were clearly mine and I could diagnose/fix them locally. :)

> I think the kill command failed to kill the processes and so I would 
> say
> this probably should be looked at by Mike Blow :)

But the kill commands don’t really explain why the tests fail in the
first place. Or do they (killing certainly could be different between
OS X and Linux)?

Anyway, what I’m looking for are hints on the tools and way to debug
these kind of failures (and one of the reasons for asking on the list
is to share the responses with everybody else).

Cheers,
Till

> On Sat, Aug 13, 2016 at 9:06 PM, Till Westmann <tillw@apache.org> 
> wrote:
>
>> Hi,
>>
>> it seems that I have RecoveryIT consistently succeeding on my box and
>> consistently failing on Jenkins [1][2].
>> Any hints what to look for from somebody who was in a similar state 
>> before?
>>
>> Thanks,
>> Till
>>
>> [1] https://asterix-jenkins.ics.uci.edu/job/asterix-gerrit-integ
>> ration-tests/309/
>> [2] https://asterix-jenkins.ics.uci.edu/job/asterix-gerrit-integ
>> ration-tests/311/
>>

Mime
View raw message